Ask Your Question
1

ROS Indigo/Jade on ARM 64 bit?

asked 2015-11-15 02:49:02 -0500

Myzhar gravatar image

Hi all,

Tomorrow Nvidia Jetson TX1 will be available in USA, it will be a big step for robotics...

Have anyone tried to compile ROS on 64 bit ARM systems? I do not know if all the dependencies can be satisfied... I'm really curious to start testing it.

Walter

edit retag flag offensive close merge delete

Comments

I'm running ROS Indigo on TK1

lanyusea gravatar image lanyusea  ( 2015-11-15 22:45:06 -0500 )edit

Jetson TK1 has a 32 bit ARM and I use it without problems since about one year and half. My doubt is about the Jetson TX1, based on the Tegra X1 that is a 64bit SoC.

Myzhar gravatar image Myzhar  ( 2015-11-16 01:09:26 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
2

answered 2015-12-14 02:14:46 -0500

tfoote gravatar image

Most ROS packages should work on ARM64. We already support 32 and 64bit x86 and most things work on armhf. So filling in the matrix is a minimal step forward.

You're right that the system dependencies are usually the limiting factor. I would expect at least up through desktop to work. With more arm64 boards coming out soon we expect to have more experience and demand for those system dependencies so hopefully they will all get filled in.

edit flag offensive delete link more
1

answered 2015-12-11 06:06:43 -0500

griz11 gravatar image

I almost have it compiled. Hung up on wxPython. Had to build rosinstall-generator rosdep and a few others. Running it in a chroot on a tx1. Gotta do the chroot to a real 64 bit fs since the tx1 has a 32 bit fs now. Managed to get it to compile and roscore started up but then an error trying to use it. So something still not kosher. WxPython is the hang up. Can't find any pre-compiled binaries for arm64 yet. Managed to get it to compile but there is something wrong with it I think. Next up going to move wxpython over to the intel box and try a cross compile on it. I know that set-up is right I'm running on the kernel I made on it.

edit flag offensive delete link more

Comments

When I submitted this question I did not know that the Jetson TX1 has a 32bit FS. After that I received it, I knew about this fact and installed ROS following the same procedure used for the Jetson TK1. Now I'm using it without any problem. Which advantages can I get using a 64bit FS and so a 64bit

Myzhar gravatar image Myzhar  ( 2015-12-11 06:52:33 -0500 )edit

Twice the bandwidth for transferring data. Especially if the software is optimized to pack 2 32 bit values into 1 64 bit value before transferring. Hopefully it won't be long before the tx1 is 64 bit. Finding the problems now is optimum. Fire up a 64bit fs on the jetson and you will see it.

griz11 gravatar image griz11  ( 2015-12-11 23:00:53 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2015-11-15 02:49:02 -0500

Seen: 1,497 times

Last updated: Dec 14 '15