Ask Your Question
0

rosdep update error

asked 2015-11-12 06:55:42 -0500

zq7734509 gravatar image

updated 2016-10-24 09:04:01 -0500

ngrennan gravatar image

I'm troubled in install ROS on my BeagleBone Black,everything runs ok until "rosdep update",for example:

ubuntu@arm:~$ rosdep update
reading in sources list data from /etc/ros/rosdep/sources.list.d
Hit https://raw.githubusercontent.com/ros/rosdistro/master/rosdep/osx-homebrew.yaml
Hit https://raw.githubusercontent.com/ros/rosdistro/master/rosdep/base.yaml
Hit https://raw.githubusercontent.com/ros/rosdistro/master/rosdep/python.yaml
ERROR: unable to process source [https://raw.githubusercontent.com/ros/rosdistro/master/rosdep/ruby.yaml]:
    <urlopen error [Errno -2] Name or service not known> (https://raw.githubusercontent.com/ros/rosdistro/master/rosdep/ruby.yaml)
ERROR: unable to process source [https://raw.githubusercontent.com/ros/rosdistro/master/releases/fuerte.yaml]:
    Failed to download target platform data for gbpdistro:
    <urlopen error [Errno 104] Connection reset by peer>
Query rosdistro index https://raw.githubusercontent.com/ros/rosdistro/master/index.yaml
ERROR: error loading sources list:
    <urlopen error <urlopen error [Errno 104] Connection reset by peer> (https://raw.githubusercontent.com/ros/rosdistro/master/index.yaml)>

There are about 5 URLs above,while only one or two will failed randomly each time,and the types of the error would be either "Connection reset by peer",or "name/service not known".I have no idea about it,p.s. my rosdep version is 0.11.4 and is the lasted version till now.

I have successfully installed ROS on my device last month,I really want to know how to resolve it. When I try "rosdep update" on my pc(ubuntu 14.04),it comes the same result,I have tried 100 times with only one time succeed Thank you for you attention!

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2015-11-12 07:29:10 -0500

gvdhoorn gravatar image

updated 2015-11-12 07:43:14 -0500

This looks like a network issue on your end (not ROS). The fact that your desktop PC has the same problems reaching github, I'd first diagnose any issues with your DNS setup (try another set of DNS servers perhaps). Do other applications show these issues as well?

edit flag offensive delete link more

Comments

Thanks for your answer first.I think my DNS is ok,because my pc can surf the internet normally,and when I open the URLs above in my browses,they can be opened as well,what's more ,if there are something wrong with my DNS ,all the URLs would be lost,but the fact is not ~

zq7734509 gravatar image zq7734509  ( 2015-11-12 08:01:33 -0500 )edit

That is not necessarily true: your browser might be more persistent (ie: try more times before giving up) than rosdep. Are you behind a proxy and / or (corporate) firewall? That might complicate things.

gvdhoorn gravatar image gvdhoorn  ( 2015-11-12 08:24:53 -0500 )edit

This is a connectivity issue. rosdep is showing the error messages received from the socket. It's especially odd that it fails on the 4th fetch from the same host, which should be a cached name lookup. Maybe you're behind a firewall which is throttling github access in some way?

tfoote gravatar image tfoote  ( 2015-11-12 15:39:36 -0500 )edit
0

answered 2017-02-28 02:20:52 -0500

melodybinbin gravatar image

updated 2017-02-28 02:24:29 -0500

It is the network issue on your end ,not ROS.Please check out your network,or change to another network.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-11-12 06:55:42 -0500

Seen: 3,051 times

Last updated: Feb 28 '17