Ask Your Question
0

ROS publisher Errors?!

asked 2015-11-06 15:57:01 -0600

JanOr gravatar image

updated 2015-11-06 17:20:43 -0600

Hi, I work with ROS Jade in Eclipse and communicate withh V-REP. And I have the following problem: Most of the times my programmruns without problems, but sometimes when I run it the following two different kind of hang ups appear.

Error Type 1:

[FATAL] [1446845672.704039636]: ASSERTION FAILED
    file = /opt/ros/jade/include/ros/publisher.h
    line = 108
    cond = false
    message = 

The error happens, when I want to publish a twist message. Also extracting the topicname from this publisher leads to this error. So I suspect, the publisher randomly has problems with the topic?! Any ideas why?

Error Type 2: The program crashes. The debugger of eclipse shows corresponding call structure:

Thread #2 [fccf_node] 17359 [core: 3] (Suspended : Signal : SIGSEGV:Segmentation fault) 
    __memcpy_sse2_unaligned() at memcpy-sse2-unaligned.S:36 0x7ffff66dfffe  
    ros::Header::write() at 0x7ffff6226e08  
    ros::Connection::writeHeader() at 0x7ffff7b0b4ec    
    ros::TransportSubscriberLink::handleHeader() at 0x7ffff7b715e4  
    ros::ConnectionManager::onConnectionHeaderReceived() at 0x7ffff7b592d3  
    ros::Connection::onHeaderRead() at 0x7ffff7b0ca17   
    ros::Connection::readTransport() at 0x7ffff7b09dca  
    ros::Connection::read() at 0x7ffff7b0a49d   
    ros::Connection::initialize() at 0x7ffff7b0a761 
    ros::ConnectionManager::tcprosAcceptConnection() at 0x7ffff7b5b4e1  
    ros::TransportTCP::socketUpdate() at 0x7ffff7b68af7 
    ros::PollSet::update() at 0x7ffff7b9521e    
    ros::PollManager::threadFunc() at 0x7ffff7b39925    
    0x7ffff6017a4a  
    start_thread() at pthread_create.c:312 0x7ffff5df6182   
    clone() at clone.S:111 0x7ffff674247d

No ideda why it's hanging... Maybe you have?

Both error appear everytime they appear at their same spot at the beginning of the program. If the program runs smoothly it keeps running. If it crashes, it crashes at the beginning.

Unfortunately I cannot provide a minimal sample, as I cannot reproduce the error. It appears randomly. I use:

 * /rosdistro: jade
 * /rosversion: 1.11.13
GNU GCC : gcc (Ubuntu 4.8.4-2ubuntu1~14.04) 4.8.4
V-REP: V-REP_PRO_EDU_V3_2_1_64_Linux

I have no clue anymore. Thanks in advance for your help!!! You are the best!

edit retag flag offensive close merge delete

Comments

Please add more details to your question including your platform, how you've installed and a minimal example of how to reproduce your issue.

tfoote gravatar imagetfoote ( 2015-11-06 16:02:20 -0600 )edit

I added the platform

JanOr gravatar imageJanOr ( 2015-11-09 02:28:51 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2015-11-09 05:00:43 -0600

JanOr gravatar image

I solved the issue. The error was some memory leakage, that produced the crashing of the publisher.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-11-06 15:57:01 -0600

Seen: 484 times

Last updated: Nov 09 '15