Ask Your Question
2

How to resolve dependency issues when installing multimaster-fkie on Ubuntu ARM?

asked 2015-09-25 10:09:34 -0500

naits3 gravatar image

Hi all,

I'm trying to install multimaster-fkie with the command

sudo apt-get install ros-indigo-multimaster-fkie

I get the following error message

--------@---------:~/catkin_ws$ sudo apt-get remove ros-indigo-multimaster-fkie Reading package lists... Done Building dependency tree
Reading state information... Done You might want to run 'apt-get -f install' to correct these: The following packages have unmet dependencies: libqt4-opengl-dev : Depends: libgles2-mesa-dev E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

when I try to run, as suggested, sudo apt-get -f install I get the following error message.

trying to overwrite '/usr/include/GLES2/gl2.h', which is also in package libraspberrypi-dev 1.20150502.d280099-1 Errors were encountered while processing: /var/cache/apt/archives/libegl1-mesa-dev_10.1.3-0ubuntu0.4_armhf.deb /var/cache/apt/archives/libgles2-mesa-dev_10.1.3-0ubuntu0.4_armhf.deb E: Sub-process /usr/bin/dpkg returned an error code (1)

So my question is: Do anyone know if it is possible to resolve the dependency issues for libegl1-mesa-dev and libgles2-mesa-dev such that the installation is successful?

Im running a ubuntu 14.04 ARM on a Raspberry PI 2. The image is taken from https://wiki.ubuntu.com/ARM/RaspberryPi

Thanks in advance :)

edit retag flag offensive close merge delete

Comments

Did you ever solve this, I receive the same error on my Raspberry Pi 2 Model B running Ubuntu 14.04?

tropic gravatar imagetropic ( 2016-02-22 15:25:26 -0500 )edit

Same for me too

mukut_noob gravatar imagemukut_noob ( 2016-03-24 13:38:21 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
2

answered 2017-03-04 15:53:23 -0500

blubbi321 gravatar image

As the above link is broken, Ill repeat (and facilitate) the solution from http://forums.raspberrypi.org/forums/... here. Also just ran into the problem ..

Basically its

sudo apt-get download libegl1-mesa-dev libgles2-mesa-dev 
sudo dpkg -i --force-overwrite /var/cache/apt/archives/libegl1-mesa-dev_10.1.3-0ubuntu0.6_armhf.deb
sudo dpkg -i --force-overwrite /var/cache/apt/archives/libgles2-mesa-dev_10.1.3-0ubuntu0.6_armhf.deb
sudo apt-get install -f

Maybe you need to replace the versions in the middle commands with something different .. tab-autocomplete is your friend ;)

edit flag offensive delete link more

Comments

Alternatively, you can specify dpkg to force overwrite through apt-get directly, e.g: sudo apt-get -o Dpkg::Options::="--force-overwrite" install libegl1-mesa-dev libgles2-mesa-dev

ruffsl gravatar imageruffsl ( 2019-06-03 01:36:47 -0500 )edit
0

answered 2016-04-07 07:28:45 -0500

mukut_noob gravatar image

Just go to this link, it worked for me and will work for you as well, all you need to do is just replace the name of your package with name described there and that's it!

Here's the link : http://www.absolutelytech.com/2010/06...

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-09-25 10:09:34 -0500

Seen: 757 times

Last updated: Mar 04 '17