Ask Your Question
0

rosws init ~/fuerte_workspace /opt/ros/fuerte & sudo apt-get install python-rosinstall

asked 2015-09-13 13:31:08 -0500

fatima gravatar image

updated 2015-09-17 01:33:04 -0500

mgruhler gravatar image

Hi im begginer and have installed ROS 2 or 3 days ago , i have some problems: 1. when i type rosws init ~/fuerte_workspace /opt/ros/fuerte i received the answer : rosws: command not found,
2. and when i type : sudo apt-get install python-rosinstall, i received the answer : Unable to fetch some archives, maybe run apt-get update or try with --fix-missing? i dont know what should i do to complete my installation so please guide me.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2015-09-17 01:38:17 -0500

mgruhler gravatar image

To 1:

This indicates that you don't have the rosws on your PATH or not installed. Due to your second question, I assume the latter.

To 2: Is this actually the only error message? If so, have you tried what it says there, i.e. have you tried to update your package definitions with sudo apt-get update? Then try to install again with sudo apt-get install python-rosinstall. This will most probably fix the issue.

On a side note: Fuerte is a VERY old ROS distro by now. I would suggest to start with ROS Indigo (if you want an LTS version) or ROS Jade (for the latest one). If you are stuck on Ubuntu 12.04 for whatever reason, at least try ROS Hydro... (and then, after Fuerte, there was even another one: Groovy. So with Fuerte you are actually behind by 4(!) releases and you will NOT receive any updates!)

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2015-09-13 13:31:08 -0500

Seen: 268 times

Last updated: Sep 17 '15