Ask Your Question
0

Last Step of installation on RPi Failing

asked 2015-09-11 14:35:47 -0500

gsav55 gravatar image

updated 2015-09-11 15:33:58 -0500

I'm following the Raspberry Pi Indigo installation guide here: http://wiki.ros.org/ROSberryPi/Instal...

CMake is failing on the last step with this error: http://i.imgur.com/P9l5Gnr.jpg

==> Processing catkin package: 'ecl_time'
==> Building with env: '/opt/ros/indigo/env.sh'
==> cmake /home/pi/ros_catkin_ws/src/ecl_core/ecl_time -DCATKIN_DEVEL_PREFIX=/home/pi/ros_catkin_ws/devel_isolated/ecl_time -DCMA
-- Using CATKIN_DEVEL_PREFIX: /home/pi/ros_catkin_ws/devel_isolated/ecl_time
-- Using CMAKE_PREFIX_PATH: /opt/ros/indigo
-- This workspace overlays: /opt/ros/indigo
-- Using PYTHON_EXECUTABLE: /usr/bin/python
-- Using Debian Python package layout
-- Using empy: /usr/bin/empy
-- Using CATKIN_ENABLE_TESTING: ON
-- Call enable_testing()
-- Using CATKIN_TEST_RESULTS_DIR: /home/pi/ros_catkin_ws/build_isolated/ecl_time/test_results
-- Found gtest sources under '/usr/src/gtest': gtests will be built
-- Using Python nosetests: /usr/bin/nosetests-2.7
-- catkin 0.6.14
CMake Error at /opt/ros/indigo/share/ecl_build/cmake/ecl_cx11.cmake:17 (message):
  Requested cxx11 flags, but this compiler does not support it.
Call Stack (most recent call first):
  CMakeLists.txt:40 (ecl_enable_cxx11_compiler)


-- Configuring incomplete, errors occurred!
<== Failed to process package 'ecl_time': 
  Command '['/opt/ros/indigo/env.sh', 'cmake', '/home/pi/ros_catkin_ws/src/ecl_core/ecl_time', '-DCATKIN_DEVEL_PREFIX=/home/pi/ros']' returned non-zero exit status 1

Reproduce this error by running:
==> cd /home/pi/ros_catkin_ws/build_isolated/ecl_time && /opt/ros/indigo/env.sh cmake /home/pi/ros_catkin_ws/src/ecl_core/ecl_timelease -G 'Unix Makefiles'

Command failed, exiting.

I'm not sure how to correct this.

edit retag flag offensive close merge delete

Comments

Please copy/paste console output into your question text: if your image ever gets deleted / the host dies, this question (and future answer) will be useless.

Be sure to format console text using the preformatted text button (the one with 101010 on it).

gvdhoorn gravatar image gvdhoorn  ( 2015-09-11 14:56:40 -0500 )edit

I edited it. It seems to be coming from

CMake Error at /opt/ros/indigo/share/ecl_build/cmake/ecl_cx11.cmake:17 (message):
  Requested cxx11 flags, but this compiler does not support it.

but I don't know how to correct it.

gsav55 gravatar image gsav55  ( 2015-09-11 15:35:25 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2015-09-30 14:42:16 -0500

Mauro gravatar image

I get the same problem. Deleting the ecl_time package doesn't help because other packages depends on it. Last June I compiled it without problems. Any help please

Mauro

edit flag offensive delete link more

Comments

The problem seems resolved. I substituted the ecl_time and ecl_devices folders with the ones in release 0.61.0 Sept 2014 and it compiles.

Mauro

Mauro gravatar image Mauro  ( 2015-09-30 15:18:34 -0500 )edit
0

answered 2015-09-11 16:29:00 -0500

MarkyMark2012 gravatar image

To be honest I would just delete the package and let the build continue. It's only trying to build a test package. ecl _time is a legacy package to boot.

Mark

edit flag offensive delete link more

Comments

Well a few of the Roomba packages that I'm trying to use depend on it.

gsav55 gravatar image gsav55  ( 2015-09-14 08:09:20 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2015-09-11 14:35:47 -0500

Seen: 403 times

Last updated: Sep 30 '15