[ar_track_alvar] Problem recognizing multiple tags [closed]

asked 2015-09-11 13:00:50 -0500

Leandro gravatar image

updated 2015-09-11 13:24:23 -0500

Hello everyone,

I'm trying to use ar_track_alvar with the kinect to recognize some block tags. I'm not so experienced with ROS or the package and need to use it for my final project. Can anyone help me?

I'm using ROS Indigo, Openni and my launch file is as follows:

<launch>
<arg name="marker_size" default="5.0" />
<arg name="max_new_marker_error" default="0.08" />
<arg name="max_track_error" default="0.2" />

<arg name="cam_image_topic" default="/camera/rgb/image_color" />
<arg name="cam_info_topic" default="/camera/rgb/camera_info" /> 
<arg name="output_frame" default="/camera_link" />

<node name="ar_track_alvar" pkg="ar_track_alvar" type="individualMarkersNoKinect" respawn="false" output="screen" args="$(arg marker_size) $(arg max_new_marker_error) $(arg max_track_error) $(arg cam_image_topic) $(arg cam_info_topic) $(arg output_frame)" />
</launch>

After I launch it, sometimes the script works, sometimes it crashes. However, when it do work, it only recognize one tag at a time. If I try to use two tags at the same time, it crashes with the following error:

roslaunch ar_track_alvar pr2_indiv_no_kinect.launch 
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

started roslaunch server http://Leandro-PC:51266/

SUMMARY
========

PARAMETERS
 * /rosdistro: indigo
 * /rosversion: 1.11.13

NODES
  /
    ar_track_alvar (ar_track_alvar/individualMarkersNoKinect)

ROS_MASTER_URI=http://localhost:11311

core service [/rosout] found
process[ar_track_alvar-1]: started with pid [22224]

[ INFO] [1441994119.349178382]: Subscribing to info topic
[ INFO] [1441994119.409040371]: AR tracker reconfigured: ENABLED 10.00 5.00 0.08 0.20
[ INFO] [1441994120.465086322]: Subscribing to image topic

[ar_track_alvar-1] process has died [pid 22224, exit code -11, cmd /opt/ros/indigo/lib/ar_track_alvar/individualMarkersNoKinect 5.0 0.08 0.2 /camera/rgb/image_color /camera/rgb/camera_info /camera_link __name:=ar_track_alvar __log:=/home/leandrosavieira/.ros/log/88bc1046-58ac-11e5-b869-a41731fbdba7/ar_track_alvar-1.log].
log file: /home/leandrosavieira/.ros/log/88bc1046-58ac-11e5-b869-a41731fbdba7/ar_track_alvar-1*.log
all processes on machine have died, roslaunch will exit
shutting down processing monitor...
... shutting down processing monitor complete
done

Does anyone know why it happens? I could make it work once but than it never worked again. I already tryed reinstalling everything, but I still get the same error.

Thanks in advance.

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2017-02-16 09:11:06.745099

Comments

In your first line you say you are using Kinect, but all the launch files you're trying to load correspond to the ones when you arent using Kinect.( you try to load individualMarkersNoKinect) . Make ssure you're using the right launch files if you're using Kinect

marauder gravatar imagemarauder ( 2015-09-11 13:33:02 -0500 )edit

Yes, I know. I'm using just the rgb camera of Kinect. If I'm not wrong, I would use the individualMarkers if I use the PointCloud data.

Leandro gravatar imageLeandro ( 2015-09-11 14:03:47 -0500 )edit

could post a link to your ar_track_alvar-1*.log file?

marauder gravatar imagemarauder ( 2015-09-11 16:22:06 -0500 )edit

Cannot find ar_track_alvar-1*.log. In the specified folder, I only have camera, roslaunch and rosout logs. I noticed sometimes the following error when running the script:*** Error in /opt/ros/indigo/lib/ar_track_alvar/individualMarkersNoKinect: corrupted double-linked list: 0x0000000000c97180 ***

Leandro gravatar imageLeandro ( 2015-09-12 11:00:39 -0500 )edit

Anyway, I installed the package using sudo apt-get install ros-indigo-ar-track-alvar. Since it worked once for me, I don't think that's the problem, but I see there's also a catkin_package for it.

Leandro gravatar imageLeandro ( 2015-09-14 07:58:10 -0500 )edit