Ask Your Question
0

a problem with launching the MoveIt! Setup Assistant

asked 2015-09-07 06:17:05 -0600

Handwerker gravatar image

updated 2015-09-07 07:27:24 -0600

gvdhoorn gravatar image

I have followed the instructions to install the MoveIt!. Now I meet an unknown error when launching the MoveIt! Setup Assistant with roslaunch moveit_setup_assistant setup_assistant.launch.

REQUIRED process [moveit_setup_assistant-1] has died!</p>
process has died [pid 14447, exit code -11, cmd /home/handwerk/moveit/devel/lib/moveit_setup_assistant/moveit_setup_assistant __name:=moveit_setup_assistant __log:=/home/handwerk/.ros/log/ba8fef58-5540-11e5-ab9d-ac72894ef665/moveit_setup_assistant-1.log].
log file: /home/handwerk/.ros/log/ba8fef58-5540-11e5-ab9d-ac72894ef665/moveit_setup_assistant-1*.log
Initiating shutdown!

My OS is Ubuntu 14.04, ROS Indigo (installed from debians).

edit retag flag offensive close merge delete

Comments

but I meet a warning when installing dependencies with rosdep install --from-paths src --ignore-src --rosdistro indigo -y

WARNING: Package "ompl" does not follow the version conventions. It should not contain leading zeros (unless the number is 0).
Handwerker gravatar imageHandwerker ( 2015-09-07 07:19:59 -0600 )edit

I must install correctly the ROS by debian. where can be the problem ?

Handwerker gravatar imageHandwerker ( 2015-09-07 07:48:49 -0600 )edit

I install the Movelt! by the first choice. Actually I haven't followed the third step ( install the ros-hydro-moveit-full-pr2 )as I don't use it.

Handwerker gravatar imageHandwerker ( 2015-09-07 08:09:13 -0600 )edit

oh! I install the moveit! also by the second choice, now I have removed the moveit file and reinstalled the moveit! by the debian packge.but the error still happens

Handwerker gravatar imageHandwerker ( 2015-09-07 09:03:54 -0600 )edit

no SEGFAULT with the apt-get moveit.

what's the meaning of rm -rf /path/to/catkin_ws/{build,devel}?

Handwerker gravatar imageHandwerker ( 2015-09-07 09:16:33 -0600 )edit

4 Answers

Sort by ยป oldest newest most voted
1

answered 2015-09-08 02:27:30 -0600

Handwerker gravatar image

unexpectedly I launched normally the moveit! setup assistant with the help of gvdhoorn. The total process was as follows:

According to the answer in the http://answers.ros.org/question/19313... I guess I had also a problem with my graphic driver.

1. I followed the http://askubuntu.com/questions/475972... to install the xserver-xorg.

sudo apt-get install xserver-xorg

sudo dpkg-reconfigure xserver-xorg

sudo reboot

but after rebooting I met the same error .And the touchpad also became invalid . then I tried to check the system Settings, but the settings crashed(could not be opened).

2. I installed the ubuntu-desktop

sudo apt-get install ubuntu-desktop

In this way the system Settings could be opened ,then I tried to launch the movit! and succeeded unexpectedly . So I think the "Exit Code -11" is probably related to both the xserver-xorg and the ubuntu-desktop.

edit flag offensive delete link more

Comments

Good to hear that you got it to work. One approach that I'd have suggested would be to run the setup assistant in GDB, so we could get a stacktrace. That would've likely showed some issue with OpenGL initialisation and / or interaction.

gvdhoorn gravatar imagegvdhoorn ( 2015-09-08 05:35:38 -0600 )edit

thanks, this approach is also worth trying,

Handwerker gravatar imageHandwerker ( 2015-09-08 07:04:44 -0600 )edit

Hello, I tried this solution but am still getting the same error as you along with "process[moveit_setup_assistant-2]: started with pid [5132] /opt/ros/indigo/lib/moveit_setup_assistant/moveit_setup_assistant: error while loading shared libraries: libmoveit_robot_state_rviz_plugin_core.so.0.7.3: "

carlos.atx gravatar imagecarlos.atx ( 2017-03-23 09:22:35 -0600 )edit
2

answered 2015-09-07 09:23:04 -0600

gvdhoorn gravatar image

updated 2015-09-07 09:24:32 -0600

Which of the tutorials did you follow? The 'Ubuntu installation' or the 'Additional Source Installation Instructions'? Also: which OS is this, which version, which ROS release and how did you install ROS (from debians, or also from source)?


Edit:

The MoveIt tutorial you linked gives you a choice:

  1. install MoveIt using apt-get ('ubuntu install): this is for 'normal' users
  2. install MoveIt by compiling from sources using catkin_make ('source installation'): this is for developers.

Which of those two options did you do?

I'm asking all of this because if you don't get SEGFAULTs with the debians, and you don't want to develop MoveIt itself, we can save us a lot of trouble by just installing the debs (and not debug your from-source build).


Edit 2:

I must install correctly the ROS by debian. where can be the problem ?

Please remove all moveit_* packages from your catkin workspace, do rm -rf /path/to/catkin_ws/{build,devel}, then run sudo apt-get install ros-indigo-moveit-full.

Then try again.


Edit 3:

I install the Movelt! by the first choice. Actually I haven't followed the third step ( install the ros-hydro-moveit-full-pr2 )as I don't use it.

/home/handwerk/moveit/devel/lib/moveit_setup_assistant/moveit_setup_assistant: this path is in the error msg you pasted in your question. That would seem to suggest you compiled moveit from sources.

Do you get the exit code -11 (SEGFAULT) with the apt-get moveit as well?


Edit 4:

oh! I install the moveit! also by the second choice, now I have removed the moveit file and reinstalled the moveit! by the debian packge.but the error still happens

no SEGFAULT with the apt-get moveit.

Good.

what's meaning of rm -rf /path/to/catkin_ws/{build,devel}?

It removes your previous 'from source' MoveIt build, to avoid you accidentally mixing those up with the MoveIt install from debs.

edit flag offensive delete link more

Comments

thanks for your attention, I follow your steps ,but the error still happens.

REQUIRED process [moveit_setup_assistant-2] has died!
process has died [pid 15519, exit code -11, cmd /opt/ros/indigo/lib/moveit_setup_assistant/moveit_setup_assistant
Handwerker gravatar imageHandwerker ( 2015-09-07 09:34:50 -0600 )edit

You'll have to provide more information then: what are you trying to do exactly? Does the setup assistant crash immediately after launching it? Or only after you load a urdf or MoveIt pkg?

As a wild guess: do you have correct 3D drivers installed for your graphics card?

gvdhoorn gravatar imagegvdhoorn ( 2015-09-07 09:36:29 -0600 )edit

actually I have no explicit destination, and only try to install correctly

yes, immediately crach after launching. I remember I have installed the full ROS.I have already met the error before installing the moveit(though maybe no need for installing the moveit)

Handwerker gravatar imageHandwerker ( 2015-09-07 10:09:09 -0600 )edit

As a wild guess: do you have correct 3D drivers installed for your graphics card?

can you run rviz normally?

gvdhoorn gravatar imagegvdhoorn ( 2015-09-07 10:12:31 -0600 )edit

l have not installed 3D drivers and run rviz.

Handwerker gravatar imageHandwerker ( 2015-09-07 10:16:39 -0600 )edit

rviz can launch correctly. I have not used the tool to do something.

Handwerker gravatar imageHandwerker ( 2015-09-07 10:26:41 -0600 )edit
0

answered 2018-11-08 23:12:57 -0600

Navaneeth gravatar image

I had the same issue but i solved it by installing ubunutu desktop

sudo apt-get install ubuntu-desktop

edit flag offensive delete link more
0

answered 2019-07-18 04:01:45 -0600

houssem trabelsi gravatar image

try to update and upgrade it works for me sudo apt-get update sudo apt-get upgrade

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2015-09-07 06:17:05 -0600

Seen: 2,749 times

Last updated: Nov 08 '18