Ask Your Question
0

-J param is not working for robots with more than 6 DOF

asked 2015-09-02 05:13:43 -0500

Samper-Esc gravatar image

updated 2015-09-02 05:27:40 -0500

Hello,

I have a robot that can be described as a robotic arm of 6 DOF attached to a mobile base (train) with 2 DOF. When I try to spawn the robot and set the initial value of the joints doing:

<!-- Spawn a robot into Gazebo -->
<node name="arm_train_spawn_urdf" pkg="gazebo_ros" type="spawn_model" args="-urdf -param robot_description -model schunk_lwa4p_DH_arm_and_train -J Joint_Train_Rail 10" respawn="false" output="screen" />

I have noticed that the train is only spawned at the position 10 of his prismatic joint if the robotic arm has 4 DOF ( 6 DOF of the whole model: 2 from the base + 4 from the arm). I would like to know if there is a way to split this xacro in 2 individual models, invoking them as 2 different robots, and attach one to another ?

Thank you in advance.

JLuis Samper

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2015-09-02 08:16:48 -0500

Samper-Esc gravatar image

updated 2015-09-02 08:17:14 -0500

I have solved it!

The problem was that the collision mesh of the mobile base that I was using was too heavy. Just had to reduce the number of points with meshlab to 8000 (more or less).

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2015-09-02 05:13:43 -0500

Seen: 44 times

Last updated: Sep 02 '15