ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

How to install ROS on Ubuntu 14.10?

asked 2015-08-28 04:46:13 -0500

prodicus gravatar image

I was going through some threads like this answer

It says that ROS Jade supports 14.10 if I am not wrong.

I am currently at this stage of the installation process.

After doing a sudo apt-get update.

Should I install Xserver again by running

sudo apt-get install xserver-xorg-dev-lts-utopic mesa-common-dev-lts-utopic libxatracker-dev-lts-utopic libopenvg1-mesa-dev-lts-utopic libgles2-mesa-dev-lts-utopic libgles1-mesa-dev-lts-utopic libgl1-mesa-dev-lts-utopic libgbm-dev-lts-utopic libegl1-mesa-dev-lts-utopic.

I am not sure whether to run the above command as it was mentioned that it can destroy the Xserver for 14.04 but obviously I am on 14.10.

Just to make it sure, so should I run the above one before I execute sudo apt-get install ros-jade-desktop-full ?

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted

answered 2015-08-28 05:53:17 -0500

dornhege gravatar image

I don't know the background of that problem, but I would only install the other packages if the ros install does not work. It should be safe to try to install ros-jade-desktop-full. Either it works or it should say that it can't work.

edit flag offensive delete link more


sudo apt-get install ros-jade-desktop-full worked in my case. Trying out the tutorials now.

prodicus gravatar image prodicus  ( 2015-08-28 05:56:28 -0500 )edit

Question Tools

1 follower


Asked: 2015-08-28 04:46:13 -0500

Seen: 209 times

Last updated: Aug 28 '15