Ask Your Question
0

ros indigo on a raspberry pi won't start because of missing roslaunch

asked 2015-08-27 12:39:44 -0500

bgewehr gravatar image

updated 2015-08-27 12:41:09 -0500

I installed ros Indigo on a brand new raspbian wheezy follwing the tutorial from the wiki.

I get this

pi@RPiMower /opt/ros/indigo/bin $ sudo ./roscore
Traceback (most recent call last):
  File "./roscore", line 62, in <module>
    import roslaunch
ImportError: No module named roslaunch

but when i start python i can Import roslaunch without Problems.

pi@RPiMower /opt/ros/indigo/bin $ python
Python 2.7.3 (default, Mar 18 2014, 05:13:23)
[GCC 4.6.3] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import roslaunch
>>>

What's wrong?

edit retag flag offensive close merge delete

Comments

Now i found

 export PYTHONPATH=$PYTHONPATH:/opt/ros/indigo/lib/python2.7/dist-packages

to solve that. Where would you put that line in?

But now i get

ROS master URI is not set

and will go on searching...

bgewehr gravatar image bgewehr  ( 2015-08-27 13:34:35 -0500 )edit

found out that export can do all that from the commandline - but is that really the way to do it? No config file or something like that?

bgewehr gravatar image bgewehr  ( 2015-08-27 14:22:36 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2015-08-27 13:32:37 -0500

duck-development gravatar image

updated 2015-08-27 13:34:57 -0500

The Problem is the use of sudo. try ist with without if you need the root rithgts then try dis

sudo su source /opt/ros/indigo/setup.bash ./roscore

or

source /opt/ros/indigo/setup.bash sudo -E ./roscore

Greet Anton

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-08-27 12:39:44 -0500

Seen: 307 times

Last updated: Aug 27 '15