Rosserial_Arduino Time and TF Tutorial: Buffer Underfill Error

asked 2015-08-25 17:45:06 -0600

RoboCD gravatar image

updated 2016-02-04 18:42:49 -0600

I am attempting tutorial 4 of the Rosserial Arduino tutorials and I keep getting an error message. I am running ROS Jade on my Ubuntu computer and have my Arduino Uno connected. Whenever I run the rosserial client application to connect to the arduino: rosrun rosserial_python serial_node.py /dev/ttyACM0 ,I get this error message:

[INFO] [WallTime: 1440542068.506962] ROS Serial Python Node 
[INFO] [WallTime: 1440542068.514658] Connecting to /dev/ttyACM0 at 57600 baud
[INFO] [WallTime: 1440542071.163000] Note: publish buffer size is 280 bytes
[INFO] [WallTime: 1440542071.163488] Setup publisher on tf [tf/tfMessage]
Traceback (most recent call last):
  File "/opt/ros/jade/lib/rosserial_python/serial_node.py", line 82, in <module>
    client.run()
  File "/opt/ros/jade/lib/python2.7/dist-packages/rosserial_python/SerialClient.py", line 482, in run
    self.callbacks[topic_id](msg)
  File "/opt/ros/jade/lib/python2.7/dist-packages/rosserial_python/SerialClient.py", line 105, in handlePacket
    m.deserialize(data)
  File "/opt/ros/jade/lib/python2.7/dist-packages/tf/msg/_tfMessage.py", line 200, in deserialize
    raise genpy.DeserializationError(e) #most likely buffer underfill
genpy.message.DeserializationError: unpack requires a string argument of length 4

I've looked around for answers and all I've found is how to increase buffer size in case of overflow. But this lists as possible buffer underfill. I've also experienced this same error when attempting tutorial 9. Please forgive me if this is an easy fix, I still consider myself fairly new to ROS but any help that can be given would be greatly appreciated.

edit retag flag offensive close merge delete