Ask Your Question
3

How to set Z axis in RVIZ?

asked 2015-08-11 22:52:45 -0500

psprox96 gravatar image

Hi all. I'm using a drone and to be display in RVIZ, I need to have a Z axis to see the height of the drone to ground.

However, my RVIZ got only the X and Y axis. Only views in 2D. My robot's frame does not go up or down, only can navigate around the 2D plane. Anyway I can set?

Thanks!

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
2

answered 2015-08-13 11:53:20 -0500

sloretz gravatar image

Sounds like RVIZ view is set to TopDownOrtho. You want to change it to Orbit.

First make sure that the panel "Views" is visible. Next to "File" is menu called "Panels". Click "Panels" and click "Views" so that it has a check mark next to it.

Next on the view panel there is a drop down box labelled "Type:". Change it to "Orbit (rviz)".

edit flag offensive delete link more

Comments

Thanks for the help!

psprox96 gravatar imagepsprox96 ( 2015-08-13 21:10:19 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-08-11 22:52:45 -0500

Seen: 235 times

Last updated: Aug 13 '15