Ask Your Question
0

Two ROS computers - roswtf: WARNING The following nodes are unexpectedly connected:

asked 2015-08-09 18:35:49 -0500

unknown_entity2 gravatar image

I'm unable to publish on /turtle1/cmd_vel with second controller computer, but it works fine on 1 computer. It works fine to send /clear service commands on 1 and 2 computer configurations.

Controller computer name computer2, node name is /rmdmia Running Turtlesim on computer name computer1.

The following is output from roswtf: WARNING The following nodes are unexpectedly connected: * unknown ( http://computer2:51117/)->/turtlesim (/turtle1/cmd_vel)

Found 1 error(s).

ERROR The following nodes should be connected but aren't: * /controlnode->/turtlesim (/turtle1/cmd_vel)

It appears to be a DNS issue, but I've set up the hosts file in both systems with each computer's ethernet ip address, set the ros_ip, and ros_hostname on computer1, and set the ros_master_uri on both systems to the hostname, instead of localhost. Any idea where the configuration is wrong?

Thanks,

Aaron

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2015-09-05 09:52:19 -0500

unknown_entity2 gravatar image

It turned out to be an XMLRPC problem. The requestTopic method had a variable that always made the address localhost, and therefore the publisher worked on localhost, and subscribers, and services always seemed to work.

Thanks,

Aaron

edit flag offensive delete link more

Comments

1

I'm a bit confused: normal ROS setups never have to change anything in XMLRPC libraries. All configuration is done using ROS_IP, ROS_HOSTNAME and ROS_MASTER_URI (as suggested by @TomSon). For two PCs and no working DNS, set ROS_IPon both and ROS_MASTER_URI to the IP of roscore machine.

gvdhoorn gravatar image gvdhoorn  ( 2015-09-05 10:31:54 -0500 )edit

You are correct that it is not a normal ROS setup. I am a developer, and it was a client I've been developing.

unknown_entity2 gravatar image unknown_entity2  ( 2015-09-08 09:23:51 -0500 )edit
0

answered 2015-08-10 02:29:56 -0500

TomSon gravatar image

ROS_MASTER_URI on your PC "Client" must look like this " http://<computer1ip>:11311

edit flag offensive delete link more

Comments

Are you saying the master URL on the destination rosnode should be ip arp, instead of dns name?

unknown_entity2 gravatar image unknown_entity2  ( 2015-08-10 17:03:15 -0500 )edit

It may help to solve your case. By the way, the main machine must be set as localhost on ROS_MASTER_URI. A schema of the configuration you want would be great.

TomSon gravatar image TomSon  ( 2015-08-11 01:56:16 -0500 )edit

I tried both IP, on main machine, and setting it to localhost in the ROS_MASTER_URI. Neither solved the issue. The following is using IP on computer2, and setting ROS_MASTER_URI of http://localhost:11311 on computer1. (using IP instead of localhost yielded the same result). The /controlnode is

unknown_entity2 gravatar image unknown_entity2  ( 2015-08-11 10:10:22 -0500 )edit

IP Address 10.42.0.2

WARNING The following nodes are unexpectedly connected: * unknown ( http://10.42.0.2:41859/)->/turtlesim (/turtle1/cmd_vel)

Found 1 error(s).

ERROR The following nodes should be connected but aren't: * /controlnode->/turtlesim (/turtle1/cmd_vel)

Any other suggestions?

unknown_entity2 gravatar image unknown_entity2  ( 2015-08-11 10:11:45 -0500 )edit
1

check your firewall and go back to Network Setup and can you provide a schematic of the different IP and environnement variables on both machines , I think it will help you to solve this issue.

TomSon gravatar image TomSon  ( 2015-08-12 01:11:43 -0500 )edit

No firewall, and I believe I am going to need to look at the xmlrpc method that creates a publishing connection. I am baffled why ros would be connected to client, but think the connection should be the node name instead of hostname or ip....

unknown_entity2 gravatar image unknown_entity2  ( 2015-08-12 02:07:28 -0500 )edit

I configured turtlesim on single machine using IP Address instead of localhost, or machine name and it works fine. Problem exists on multiple machines regardless of configuration, and I've gone to the extent of implementing multiple XMLRPC calls to troubleshoot, all seem good: getURI(/controlnode):

unknown_entity2 gravatar image unknown_entity2  ( 2015-08-14 19:08:08 -0500 )edit

This forum says my content is forbidden. If I try to paste data here from XMLRPC calls.

unknown_entity2 gravatar image unknown_entity2  ( 2015-08-14 19:09:17 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-08-09 18:35:49 -0500

Seen: 1,434 times

Last updated: Sep 05 '15