Ask Your Question
1

Roslaunch using different port?

asked 2015-08-06 06:25:11 -0600

Vasu Agrawal gravatar image

I'm attempting to use roslaunch to start nodes on 2 different machines. Apparently roslaunch will create it's own ssh connection - I have my network configured so that I use public / private keys for authentication, but I've set the ssh to be done over a different port. How would I configure my roslaunch file to do the same? (i.e. port 42 instead of 22)

Current file:

<launch>
  <machine name="bbb" address="bbb -p 4242" user="sparky"/>
  <machine name="spearmint" address="localhost" default="true" />
  ....
</launch>

Obviously that's the wrong syntax, but that's what I'm trying to achieve.

For reference, I can run ssh sparky@bbb -p 4242 and connect just fine.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
2

answered 2019-01-10 10:23:56 -0600

fbelmonteklein gravatar image

updated 2019-01-10 10:40:06 -0600

gvdhoorn gravatar image

there is an example from ros-comm on how to do this, basically it is an undocumented parameter ssh-port you need to set on <machine> like:

<launch>
    <machine name="machine-1" default="true" address="foo.bar.com" ros-root="/home/user/ros/ros/" user="whoami" ssh-port="4242" />
</launch>

see here: https://github.com/ros/ros_comm/blob/...

edit flag offensive delete link more

Comments

2

@fbelmonteklein: I've marked your answer as the answer and removed mine.

gvdhoorn gravatar imagegvdhoorn ( 2019-01-10 10:40:38 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-08-06 06:25:11 -0600

Seen: 657 times

Last updated: Jan 10