Ask Your Question
0

ROS indigo installation error

asked 2015-07-30 04:44:54 -0500

mruniverse gravatar image

hi i am trying to install ROS indigo but when i am trying to set up my keys

sudo apt-key adv --keyserver hkp://pool.sks-keyservers.net --recv-key 0xB01FA116

its showing the following error in terminal window

  gpg: requesting key B01FA116 from hkp server pool.sks-keyservers.net
gpg: keyserver timed out
 gpg: keyserver receive failed: keyserver error
edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2015-07-30 06:22:05 -0500

gvdhoorn gravatar image

updated 2015-07-30 06:23:13 -0500

This is probably a transient error. Please try again after some time.

Also, see ROS indigo key server down for an alternative in case you don't want to wait for it to come back up.

edit flag offensive delete link more

Comments

can i use the command below instead of the steps in the offical site??

wget https://raw.githubusercontent.com/oroca/oroca-ros-pkg/master/ros_indigo_install.sh && sudo sh./ros_indigo_install.sh
mruniverse gravatar imagemruniverse ( 2015-07-30 09:45:06 -0500 )edit

somneone told me this install ros in one go

mruniverse gravatar imagemruniverse ( 2015-07-30 09:46:14 -0500 )edit

Up to you. ROS installation is really only a few lines anyway. Just make sure the file does what you expect it to.

gvdhoorn gravatar imagegvdhoorn ( 2015-07-30 10:01:34 -0500 )edit

hi ni ahve installed ros and setup my workspace but whenever i am opening the terminal this is showing again and again

bash: source~/Desktop/kinectrobot/devel/setup.bash: No such file or directory universe@universe-HP-202-G2-MT:~$

after type the clear command its not there

mruniverse gravatar imagemruniverse ( 2015-08-03 02:27:19 -0500 )edit

I cannot find that in the script you linked, so it's probably something that you did. Please open a new question for this unrelated issue.

gvdhoorn gravatar imagegvdhoorn ( 2015-08-03 02:41:54 -0500 )edit
0

answered 2016-07-04 13:18:13 -0500

Try add :80 port after server link: Like: sudo apt-key adv --keyserver hkp://pool.sks-keyservers.net:80 --recv-key 0xB01FA116

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-07-30 04:44:54 -0500

Seen: 1,103 times

Last updated: Jul 30 '15