Problem with Turtlebot pkg [closed]

asked 2015-07-22 04:44:38 -0500

Alvaro Salcedo gravatar image

Hi Ros Users:

I have a problem with turtlebot pkg. I have just instaled and when I run

roslaunch turtlebot_gazebo turtlebot_world.launch

I can see this problem on the terminal:

> while processing
> /home/alcor/catkin_ws/src/turtlebot_simulator-indigo/turtlebot_gazebo/launch/includes/kobuki.launch.xml:
> Invalid <param> tag: Cannot load
> command parameter [robot_description]:
> command
> [/opt/ros/indigo/share/xacro/
> '/home/alcor/catkin_ws/src/turtlebot-indigo/turtlebot_description/robots/kobuki_hexagons_asus_xtion_pro.urdf.xacro']
> returned with code [1]. 
> Param xml is <param command="$(arg
> urdf_file)" name="robot_description"/>
> The traceback for the exception was
> written to the log file

How can I fix it?


edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alvaro Salcedo
close date 2015-07-23 05:15:49.472197


have you checked that you have the file: /home/alcor/catkin_ws/src/turtlebot-indigo/turtlebot_description/robots/kobuki_hexagons_asus_xtion_pro.urdf.xacro?

Javier V. Gómez gravatar image Javier V. Gómez  ( 2015-07-22 05:47:07 -0500 )edit

Thanks for your response! I have just fixed! I had to install more drivers.

Alvaro Salcedo gravatar image Alvaro Salcedo  ( 2015-07-23 05:15:31 -0500 )edit

Can you please let me know how you fixed this issue? I am getting the same error. What drivers did you have to install?

Sandeep gravatar image Sandeep  ( 2016-01-27 22:32:08 -0500 )edit

the drivers can be sourced from the updated turtlebot repository

xcelsior gravatar image xcelsior  ( 2017-04-24 19:40:14 -0500 )edit