ardrone_autonomy, periodically reduced sampling frequency [closed]

asked 2015-07-14 01:12:19 -0500

Milkbot gravatar image

updated 2015-07-15 02:01:14 -0500

Hi, I'm using ardrone_autonomy to read data from the Parrot AR Drone 2.0, with ROS on an Ubuntu system. Most of the time it works fine, with ROS receiving data at the ideal rate of around 180-200 Hz. However, once every 1-2 minutes, the sampling rate is reduced to around 8-20 Hz, which messes up for the closed loop control system I'm designing. This condition lasts for about 6 seconds at every occurrence. Does anyone have any idea what this might be because? I have tried two drones, both with the same error, so it's probably not due to the drone.

EDIT: Added the link below to the picture of a recorded .bag file visualized in rqt. Each blue line represents a received sample, while white spaces mean "no sample". A recording of the "ardrone/navdata" topic shows the same.

http://cubeupload.com/im/hS59vZ.jpg

(ALT) http://i.cubeupload.com/hS59vZ.jpg

Thanks in advance!

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2018-01-11 20:22:58.774371

Comments

Have you tried running the driver on another computer? It might be due a network issue? Is the host computer a notebook? Are you using an internal wifi card?

Mani gravatar imageMani ( 2015-08-06 20:18:31 -0500 )edit

I have not tried the driver on another machine, as I currently only have access to one. It's a laptop and yes, I'm using its internal wireless card for the connection.

Thanks for taking the time to comment! :)

Milkbot gravatar imageMilkbot ( 2015-08-07 00:29:40 -0500 )edit

It might be worth noting that as far as I've experienced, this does not seem to occur when connected to other networks, such as internet connections etc. Though this may simply be due to me failing to notice.

Milkbot gravatar imageMilkbot ( 2015-08-07 00:34:24 -0500 )edit