ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question


asked 2015-07-12 13:26:36 -0500

janis gravatar image


I created a workspace and cloned ROS_openTLD from, and I run it in the following way, cd ros_opentld ; source devel/ ; roslaunch tld_tracker ros_tld_tracker.launch ; roslaunch tld_tracker ros_tld_gui.launch.

but I don't know why there is always no image showing on the tld_gui window. I thought maybe I need to edit 'image_topic' in the launch file to the specific topic I used, but I don't know how to modify the <remap from="image" to="$(arg image_topic)"/>. I'm not sure whether the modification is necessary. I am new to ROS and sorry I ask the silly question. Someone else know the problem and can help? Thank you.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2015-07-12 17:13:38 -0500

janis gravatar image

Knowing the function of arg image_topic, I solved the problem by

roslaunch tld_tracker ros_tld_gui.launch image_topic:=/camera/image_raw
roslaunch tld_tracker ros_tld_tracker.launch image_topic:=/camera/image_raw
edit flag offensive delete link more

Question Tools

1 follower


Asked: 2015-07-12 13:26:36 -0500

Seen: 368 times

Last updated: Jul 12 '15