3d mouse with ros [closed]

asked 2015-07-10 12:30:40 -0500

rmoncrief gravatar image

updated 2015-07-13 08:23:26 -0500

gvdhoorn gravatar image

I am trying to connect a 3d space mouse to ros to publish to A dynamixel motor. I am following the tutorial ( http://wiki.ros.org/threeD_mouse )about how to start the 3d mouse but I keep getting this error. can anyone explain what I have done wrong?

[ rosmake ] rosmake starting...                                                 
[ rosmake ] Packages requested are: ['threeD_mouse']                            
[ rosmake ] Logging to directory /home/rsgros/.ros/rosmake/rosmake_output-20150710-132505
[ rosmake ] Expanded args ['threeD_mouse'] to:
[]                               
[ rosmake ] WARNING: The following args could not be parsed as stacks or packages: ['threeD_mouse']
[ rosmake ] ERROR: No arguments could be parsed into valid package or stack names.

when I run the rosmake command. I have downloaded the libraries it tells me to and have put them in my home directory. I am running hydro also.

When I run "rosmake spacenav" seen on this page ( http://wiki.ros.org/spacenav ) I get the error:

[ rosmake ] rosmake starting...
[ rosmake ] Packages requested are: ['spacenav']
[ rosmake ] Logging to directory /home/rsgros/.ros/rosmake/rosmake_output-20150713-090536
[ rosmake ] Expanded args ['spacenav'] to:
[]                                                                               
[ rosmake ] WARNING: The following args could not be parsed as stacks or packages: ['spacenav']
[ rosmake ] ERROR: No arguments could be parsed into valid package or stack names.

also when I run "rosdep install spacenav_node" from here ( http://wiki.ros.org/spacenav_node/Tut... ) I get the error:

ERROR: Rosdep cannot find all required resources to answer your query
Missing resource spacenav_node
ROS path [0]=/opt/ros/hydro/share/ros
ROS path [1]=/home/rsgros/cyton_gamma_300_ROS/ROS_ws/src
ROS path [2]=/home/rsgros/catkin_ws/src
ROS path [3]=/opt/ros/hydro/share
ROS path [4]=/opt/ros/hydro/stacks

But I assume that is from the "romake spacenav" command is failing.

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2018-01-11 20:33:54.930101

Comments

I am following the tutorial [..]

Please add a link to the specific tutorial you are referring to.

gvdhoorn gravatar imagegvdhoorn ( 2015-07-11 03:56:44 -0500 )edit

Added it in the post. Sorry I forgot to paste it in before

rmoncrief gravatar imagermoncrief ( 2015-07-11 12:58:54 -0500 )edit
2

I think the spacenav_node is better supported, and supports the same devices.

ahendrix gravatar imageahendrix ( 2015-07-11 23:56:24 -0500 )edit

will this work on hydro or will I have to go back to fuerte? Also I added more detail about what is happening in the question. I have the spacenav folder downloaded from http://spacenav.sourceforge.net/

rmoncrief gravatar imagermoncrief ( 2015-07-13 08:01:59 -0500 )edit

If you navigate to the URL that @ahendrix posted, you'll see that you can install this on everything up to Jade. A simple sudo apt-get install ros-hydro-spacenav-node should suffice. Why in the world would you go to sourceforge and try to build random things from source?

gvdhoorn gravatar imagegvdhoorn ( 2015-07-13 08:22:01 -0500 )edit
1

In general: don't build things from source, unless you absolutely have to. Use the Ubuntu Software Centre, the Synaptic pkg mgr or dpkg to search for binary versions of the pkgs you want to install. Only if that fails, you should attempt to build-from-sources. Or if you need to edit the sources.

gvdhoorn gravatar imagegvdhoorn ( 2015-07-13 08:25:38 -0500 )edit