Ask Your Question
0

Why rosdep install doesn't work?

asked 2015-07-08 22:16:13 -0500

vince gravatar image

updated 2015-07-09 02:24:42 -0500

gvdhoorn gravatar image

Hello, I am trying to install the rosaria package trough rosdep but when I run the command rosdep install rosaria along this tutorial this is what I obtain :

robotics@robotics-MacBookAir:~/catkin_ws/src$ rosdep install rosaria
Executing script below with cwd=/tmp
{{{
#!/bin/bash
if test "x`dpkg-query -W -f='${Package} ${Status} ${Version}\n' libaria-sourcedep`" != 'xlibaria-sourcedep install ok installed 2.8.0-1'; then
 echo "libaria-sourcedep not installed"
  exit 1
else
  exit 0
fi

}}}

#All required rosdeps installed successfully
robotics@robotics-MacBookAir:~/catkin_ws/src$

And then if I try to run: rosrun rosaria RosAria, nothing happen and it crashes.

UPDATE:

This is what I obtain when I run :

roscd && cd ../src
cd ..
catkin_make

git clone https://github.com/amor-ros-pkg/rosaria.git
robotics@robotics-MacBookAir:~/catkin_ws/src$ roscd && cd ../src
robotics@robotics-MacBookAir:~/catkin_ws/src$ git clone https://github.com/amor-ros-pkg/rosaria.git
fatal: destination path 'rosaria' already exists and is not an empty directory.
robotics@robotics-MacBookAir:~/catkin_ws/src$ cd ..
robotics@robotics-MacBookAir:~/catkin_ws$ catkin_make
Base path: /home/robotics/catkin_ws
Source space: /home/robotics/catkin_ws/src
Build space: /home/robotics/catkin_ws/build
Devel space: /home/robotics/catkin_ws/devel
Install space: /home/robotics/catkin_ws/install
####
#### Running command: "make cmake_check_build_system" in "/home/robotics/catkin_ws/build"
####
####
#### Running command: "make -j2 -l2" in "/home/robotics/catkin_ws/build"
####
[  0%] Built target std_msgs_generate_messages_cpp
[  0%] [ 16%] Built target rosaria_gencfg
Built target geometry_msgs_generate_messages_cpp
[ 16%] Built target std_msgs_generate_messages_lisp
[ 16%] [ 16%] Built target geometry_msgs_generate_messages_lisp
Built target geometry_msgs_generate_messages_py
[ 16%] Built target std_msgs_generate_messages_py
[ 33%] Built target rosaria_generate_messages_cpp
[ 50%] Built target rosaria_generate_messages_lisp
[ 83%] Built target rosaria_generate_messages_py
[ 83%] Built target rosaria_gencpp
[ 83%] Built target rosaria_generate_messages
[100%] Built target RosAria
robotics@robotics-MacBookAir:~/catkin_ws$

Do you have an idea about what would be the cause of this problem?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2015-07-08 22:22:44 -0500

allenh1 gravatar image

updated 2015-07-08 22:27:25 -0500

That's not actually installing ROSAria. You need to compile the source. Run the following.

$ roscd && cd ../src
$ git https://github.com/amor-ros-pkg/rosaria.git
$ cd ../ && catkin_make

But, as a side note, you can use p2os to work with Pioneer robots by using apt-get.

sudo apt-get install ros-jade-p2os-*
edit flag offensive delete link more

Comments

Thank you for the reply, I've already try git clone https://github.com/amor-ros-pkg/rosar.. . then catkin_make but when I do rosrun rosaria RosAria nothing at all happens. I wonder it was because of rosdep.

vince gravatar image vince  ( 2015-07-08 23:56:59 -0500 )edit

I also tried sudo apt-get install ros-jade-p2os-*, it seems working but I get errors. I need to fix that but I would prefer working with RosAria since I use to.

vince gravatar image vince  ( 2015-07-08 23:59:20 -0500 )edit

Could you update your question with the output of the relevant commands? I also might suggest you run source ~/catkin_ws/devel/setup.bash and try ROSAria again. But if you're getting errors with p2os, please let me know, as I'm the p2os maintainer.

allenh1 gravatar image allenh1  ( 2015-07-09 00:14:42 -0500 )edit

I have already source after catkin_make, in that case it does not find the package but here, it finds it but nothing about even that it cannot find the master. For p2os I have already fix it, but I am wondering if I need p2os_dashboard package because it does not exist.

vince gravatar image vince  ( 2015-07-09 00:47:40 -0500 )edit

You do not need p2os_dashboard. I'm actually planning to completely redo that program. But it is not anywhere close to a necessity. Unfortunately, I cannot help much with ROSAria.

allenh1 gravatar image allenh1  ( 2015-07-09 11:34:11 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-07-08 22:16:13 -0500

Seen: 457 times

Last updated: Jul 09 '15