Ask Your Question
0

Hokuyo laser getID failed. How to fix it?

asked 2015-07-08 17:02:32 -0500

Truce gravatar image

While running the rosrun hokuyo_node, I get the error getID failed: timeout reached (in hokuyo::laser::laserReadLine)

how to fix it. I followed the Hokuyo tutorials. And I have given it permission.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2015-07-09 12:24:17 -0500

updated 2015-07-09 12:28:45 -0500

Make sure the laser driver is installed correctly and the system can read it. Connect your laser and check if the system can detect it and if it is configured correctly.

$ ls -l /dev/ttyACM0

When the laser is connected, the system can see it using the following command line:

crw-rw-rw- 1 root dialout 166, 0 Jun 15 11:17 /dev/ttyACM0

Once everything is OK, we are going to switch on the laser. Start roscore in one shell and in another shell execute the following command:

$ rosrun hokuyo_node hokuyo_node

If everything is fine, you will see the following output:

[ INFO] [1378076340.184643618]: Connected to device with ID: H10XX40X
edit flag offensive delete link more

Comments

Yes I did whatever you said. It worked fine till : crw-rw-rw- 1 root dialout 166, 0 Jun 15 11:17 /dev/ttyACM0

then trying to get ID i was getting error. Somehow after taking a break and restarting everything. It worked. Thanks for your help.

Truce gravatar imageTruce ( 2015-07-10 10:38:39 -0500 )edit

On the youbot there should also be a /dev/sensors/hokuyo symlink that you can set by:

$ rosparam set hokuyo_node/port /dev/sensors/hokuyo
85pando gravatar image85pando ( 2015-09-25 07:24:15 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-07-08 17:02:32 -0500

Seen: 444 times

Last updated: Jul 09 '15