Could not find or load the Qt platform plugin "xcb".

asked 2015-07-05 09:07:18 -0500

SamTew gravatar image

updated 2015-07-07 10:19:56 -0500

allenh1 gravatar image
 sam@sam-X450LCP:~$ rosrun image_view image_view image:=/camera/depth_registered/image_raw
[ INFO] [1436104815.972634092]: Using transport "raw"

This application failed to start because it could not find or load the Qt platform plugin "xcb".

Reinstalling the application may fix this problem.
Aborted (core dumped)

I use freenect_launch to activate kinect. Nothing is strange except this warning.

[ WARN] [1436104496.653971362]: Could not find any compatible depth output mode for 1. Falling back to default depth output mode 1.

Can anyone help me?

edit retag flag offensive close merge delete


Did you try sudo apt-get install xcb?

allenh1 gravatar image allenh1  ( 2015-07-06 11:29:51 -0500 )edit

i have tried but it still the same. Thanks anyway.

SamTew gravatar image SamTew  ( 2015-07-07 07:14:16 -0500 )edit

What version of ubuntu are you running? What happens if you type qmake --version?

allenh1 gravatar image allenh1  ( 2015-07-07 10:18:12 -0500 )edit

I'd like to push this thread, because I have exactly the same problem and can't find a solution. I tried installing xcb and qmake --version gives QMake version 3.0 Using Qt version 5.5.1 in /usr/lib/x86_64-linux-gnu Interestingly this problem occured a few days ago, I don't know when exactly.

mherrmann gravatar image mherrmann  ( 2018-05-17 10:36:51 -0500 )edit

@mherrmann are you still having this issue? Sorry, was not on ROS answers for a good while

allenh1 gravatar image allenh1  ( 2018-08-02 15:18:26 -0500 )edit

@allenh1 Thanks for your reply, my problem can be traced back to an installation of a camera driver, which installed a second qt5 version and added the search path. More details here:

mherrmann gravatar image mherrmann  ( 2018-08-06 01:44:33 -0500 )edit

Hey @mherrmann I'm running into the same error. Could you provide some details on how you fixed it? 1&2 of the stackoverflow did not help my case.

agerami gravatar image agerami  ( 2020-07-14 19:02:45 -0500 )edit