ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Installation and configuration Asus Xtion Pro (0600) on Ubuntu 14.04

asked 2015-06-22 12:57:19 -0500

Saracerno gravatar image

Hi, I'm a student and i am trying to use an Asus Xtion through ROS ,on an Ubuntu14.04 laptop . My version of ROS is Indigo. I would be very gratefull if someone could explain me the method of installation. Precisely i'm interested to catch data from openNI and visualize to RViz. Thank you.

edit retag flag offensive close merge delete


Hi @Saracerno! Try to check this post.

Chaos gravatar image Chaos  ( 2015-06-24 02:31:37 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted

answered 2015-06-22 15:04:33 -0500

You should start by installing openni_launch using sudo apt-get install ros-indigo-openni-launch and then following the instructions for Quick Start on that package's main page. If you are lucky this will work fine. If you are running into errors, I'd then try using openni2_launch. If you are still running into errors, then start searching the internet for your specific errors. There are many people on this site who have asked about a variety of different errors, and many of the questions have several debugging steps that you can try. If you get nowhere with this, then come back here and post what you've tried, and what errors you are getting. Unfortunately the functionality of these devices can be somewhat finicky, and many systems behave differently even with the same drivers and devices. That being said, I am usually able to find some combination of driver version and specific port where I can get everything working.

edit flag offensive delete link more

answered 2016-01-08 11:52:11 -0500

soichirutk gravatar image

I had some troubles with ROS indigo, and then I tried installing ros-indigo-rgbd-launch ros-indigo-openni2-camera ros-indigo-openni2-launch, and also I modified the files sudo nano /usr/etc/primesense/GlobalDefaults.ini uncommented ";UsbInterface=2" . So The only problem that I have now is this warning "Warning: USB events thread - failed to set priority. This might cause loss of data...", If you want to try it.

edit flag offensive delete link more

Question Tools


Asked: 2015-06-22 12:57:19 -0500

Seen: 2,621 times

Last updated: Jan 08 '16