Ask Your Question
0

Softkinetic node StreamingException with senz3D

asked 2015-06-09 16:41:27 -0500

splash gravatar image

Hi,

I try to use a Creative Senz3D with the softkinetic node from https://github.com/ipa320/softkinetic . I have installed the DepthSense SDK and I can view the image stream with the sample program from the SDK. But I get a "DepthSense::StreamingException" when I start the softkinetic node. I get this error with every color_frame_format setting. If I disable the color image in the config the nodes starts without error. So it has something to do with the color image stream. I use ros indigo on a system with ubuntu 14.04.2 and tried USB 3.0 and 2.0 ports.

Here is the console output from softkinetic_camera_ds325.launch:

pmsr@rts-sim-3:~/ros_workspace/catkin_ws/src/ros_depthsense_camera/launch$ roslaunch softkinetic_camera softkinetic_camera_ds325.launch 
... logging to /home/pmsr/.ros/log/3418d49a-0549-11e5-a9b4-d8cb8a4f9f37/roslaunch-rts-sim-3-13950.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

started roslaunch server http://rts-sim-3:44319/

SUMMARY
========

PARAMETERS
 * /rosdistro: indigo
 * /rosversion: 1.11.13
 * /softkinetic_camera/camera_link: softkinetic_camer...
 * /softkinetic_camera/color_compression: MJPEG
 * /softkinetic_camera/color_frame_format: WXGA
 * /softkinetic_camera/color_frame_rate: 25
 * /softkinetic_camera/confidence_threshold: 200
 * /softkinetic_camera/depth_frame_format: QVGA
 * /softkinetic_camera/depth_frame_rate: 25
 * /softkinetic_camera/depth_mode: close
 * /softkinetic_camera/enable_color: True
 * /softkinetic_camera/enable_depth: True
 * /softkinetic_camera/min_neighbours: 50
 * /softkinetic_camera/search_radius: 0.05
 * /softkinetic_camera/use_radius_outlier_filter: False
 * /softkinetic_camera/use_voxel_grid_filter: False
 * /softkinetic_camera/voxel_grid_size: 0.03

NODES
  /
    softkinetic_camera (softkinetic_camera/softkinetic_bringup_node)

auto-starting new master
process[master]: started with pid [13962]
ROS_MASTER_URI=http://localhost:11311

setting /run_id to 3418d49a-0549-11e5-a9b4-d8cb8a4f9f37
process[rosout-1]: started with pid [13975]
started core service [/rosout]
process[softkinetic_camera-2]: started with pid [13992]
[ INFO] [1432824767.747549238]: Number of Devices found: 1
Argument Exception: argument "node": context already has control over the node
terminate called after throwing an instance of 'DepthSense::StreamingException'
  what():  VIDIOC_STREAMON failed (No space left on device)
[softkinetic_camera-2] process has died [pid 13992, exit code -6, cmd /home/pmsr/ros_workspace/catkin_ws/devel/lib/softkinetic_camera/softkinetic_bringup_node 0 __name:=softkinetic_camera __log:=/home/pmsr/.ros/log/3418d49a-0549-11e5-a9b4-d8cb8a4f9f37/softkinetic_camera-2.log].
log file: /home/pmsr/.ros/log/3418d49a-0549-11e5-a9b4-d8cb8a4f9f37/softkinetic_camera-2*.log

What else can I try to get the node working?

edit retag flag offensive close merge delete

Comments

Please report bugs/issues at the ipa320/softkineticissue tracker.

gvdhoorn gravatar image gvdhoorn  ( 2015-06-10 04:28:40 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2015-11-26 08:28:08 -0500

callemein gravatar image

Sometimes it's a permission problem. Or a lib problem.

Here the same Streaming Exeption is given:

http://www.softkinetic.com/support/Fo...

I've solved it by checking this:

(From the link)

I export the DepthSense Library with "export LD_LIBRARY_PATH=/opt/softkinetic/DepthSenseSDK/lib/", with "echo $LD_LIBRARY_PATH" I get this line:

/opt/softkinetic/DepthSenseSDK/lib/.

All seem ok!

Then you should look into your /opt/softkinetic/DepthSenseSDK/lib folder

Mine looks like this:

libDepthSensePlugins.so@    libDepthSensePlugins.so.1.4.5  libDepthSense.so.1@     libturbojpeg.so  libusb-1.0.so.0
libDepthSensePlugins.so.1@  libDepthSense.so@              libDepthSense.so.1.4.5  libusb-1.0.so    libusb-1.0.so.0.1.0

The "libDepthSensePlugins.so" file links to the "ibDepthSensePlugins.so.1", same thing with the libDepthSense files.

I remember that i had to create that one myself to fix an issue. Can't seem to find the documentation where that solution is found. But credits go to him :-p

To create the links

ln -s /opt/softkinetic/DepthSenseSDK/lib/libDepthSensePlugins.so.1 /opt/softkinetic/DepthSenseSDK/lib/libDepthSensePlugins.so
ln -s /opt/softkinetic/DepthSenseSDK/lib/libDepthSense.so.1 /opt/softkinetic/DepthSenseSDK/lib/libDepthSense.so
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-06-09 16:41:27 -0500

Seen: 708 times

Last updated: Nov 26 '15