Ask Your Question
1

ImportError: No module named roslaunch

asked 2015-06-04 05:34:18 -0600

DarkPatate gravatar image

Hello,
I'm trying to launch the roslaunch kobuki_node minimal.launch command in my software (a Qt app, more precisely). Firstly, I was forced to use /opt/ros/indigo/bin/roslaunch command instead of roslaunch to have a result.

Unfortunatly, the complete command doesn't work. With a QProcess, I have no result. When I use the standard C execv command, I have the below result:

Traceback (most recent call last): File "/opt/ros/indigo/bin/roslaunch", line 34, in <module> import roslaunch ImportError: No module named roslaunch

Do you have an idea to solve the problem?
Thanks in advance!
DarkPatate.

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2015-06-04 05:50:44 -0600

gvdhoorn gravatar image

See How to run ROS commands from C++ application? for (what seems to be) an identical issue.

In short: you're probably starting roslaunch from an environment that has not been setup for use with ROS (ie: ROS_PACKAGE_PATH, PYTHONPATH, etc have not been set properly).

Other related questions:

edit flag offensive delete link more

Comments

Thanksfor your answer. I saw your last link before. I tried to call the export ROS_PACKAGE_PATH=/home/maneesh/ros_stacks:$ROS_PACKAGE_PATH command, without succes.

According your first link, I tried the bash -i -c \"roslaunch kobuki_node minimal.launch\" command. (1/3)

DarkPatate gravatar imageDarkPatate ( 2015-06-04 06:16:23 -0600 )edit

The previous error disapear instead of a new one:
bash: impossible de régler le groupe de processus du terminlal (1718): Ioctl() inappropré pour un périphérique
bash: pas de contrôle de tâche dans ce shell
In english (handmade translation): (2/3)

DarkPatate gravatar imageDarkPatate ( 2015-06-04 06:19:24 -0600 )edit

bash: impossible to adjust the terminal process group (1718): Ioctl() innappropriate for a device
bash: no task control in this shell (3/3)

DarkPatate gravatar imageDarkPatate ( 2015-06-04 06:21:16 -0600 )edit

Have you resolved this?

Dr Abdul Mannan gravatar imageDr Abdul Mannan ( 2016-11-14 06:05:04 -0600 )edit

I have the same problem and don't know how to solve it. Need some advice.

billgaspeed gravatar imagebillgaspeed ( 2018-10-02 21:47:27 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-06-04 05:30:08 -0600

Seen: 2,149 times

Last updated: Jun 04 '15