Ask Your Question
0

Problem with keep_time of the social navigation layer

asked 2015-06-03 13:22:45 -0500

zeinab gravatar image

updated 2015-06-03 14:36:44 -0500

Hi, I need to change the keep_time of the social navigation layer to keep the legs for more than 2 seconds e.g. 30 seconds. I understand this layer is dynamic and it makes sense for it not to stay the same so long but there are cases which need to have this keep _time larger. I think this layer forces keep_time to be less than 2 since my configuration in the local and global costmaps for the social layer where translated to 2s instead of 30s.

Any idea on how to do this? I could not find where this condition is checked in the source code. Thanks in advance for your help. I have changed the config folder's max value and also manually changed the code. I think this parameter is set but is never used in the code. people_keep_time_ is never used. @David Lu

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2015-06-04 21:24:38 -0500

David Lu gravatar image

That looks to be true. Please fill out an issue here: https://github.com/DLu/navigation_lay...

Pull requests are welcome.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-06-03 13:22:45 -0500

Seen: 168 times

Last updated: Jun 04 '15