Ask Your Question
0

ekf_localization_node type error for topic imu0

asked 2015-05-22 05:15:58 -0600

charles.fox gravatar image

updated 2015-05-22 05:42:51 -0600

Tom Moore gravatar image

I'm setting up a ekf_localization_node and feeding it with a Sensor_msgs/Imu message (from a Razor), but getting this error,

ERROR 1432289505.280310120: ERROR reading sensor update config: type error for topic imu0 (type: 0, expected: 7) WARN 1432289505.280386707: Warning: imu is listed as an input topic, but all its update variables are false

despite having,

$rostopic type imu

sensor_msgs/Imu

any ideas what's wrong with this? What do the types 0 and 7 mean here, and is there a way to look them up?

Further details, here's my launch,

<launch>
  <node pkg="robot_localization" type="ekf_localization_node" output="screen"  name="ekf_localization_node">
    <param name="odom0" value="odometry/gps"/>
    <param name="imu0" value="imu"/>
    <rosparam param="odom0_config">[true,  true,  false,
                                    false,  false,  false,
                                    false,  false, false,
                                    false, false, false,
                                    false, false, false]</rosparam>
    <rosparam param="imu0">[false,  false,  false,
                            false  false,  true,
                            false,  false, false,
                            false, false, true,
                            true, false, false]</rosparam>
    <param name="odom0_differential" value="false"/>
  </node>
</launch>

I still get the same error message about type 0 vs type 7 if I comment out all references to imu in the launch params, suggesting something may be wrong with the way imu is specified in the launch ?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2015-05-22 05:44:17 -0600

Tom Moore gravatar image

Your IMU0 configuration is specified incorrectly. You have this:

 <rosparam param="imu0">[false,  false,  false,
                        false  false,  true,
                        false,  false, false,
                        false, false, true,
                        true, false, false]</rosparam>

You want this:

<rosparam param="imu0_config">[false,  false,  false,
                        false  false,  true,
                        false,  false, false,
                        false, false, true,
                        true, false, false]</rosparam>
edit flag offensive delete link more

Comments

Yes I had overrwitten the imu0 param with its config vector, hence the type mix up. Thanks for the super fast reply !

charles.fox gravatar imagecharles.fox ( 2015-05-22 05:49:50 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-05-22 05:15:58 -0600

Seen: 437 times

Last updated: May 22 '15