ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

ccny_rgbd_tools-0.1.1 compilation issue with ROS-hydro.

asked 2015-05-21 16:46:12 -0500

Tanmay gravatar image

updated 2015-05-22 12:55:49 -0500


I am trying to use the ccny_rgbd_tools SLAM package, I'm running Ubuntu 12.04 and ROS-hydro (rosbuild / hydro_workspace, primarily).

Since I was running into libg2o issues, so when I cloned the repository, I had tried the groovy , hydro , and master branches of ccny_rgbd_tools, but to no luck. After facing a lot of issues with libg2o (whether or not I have libg2o installed - I've tried both), I shifted to the ccny_rgbd_tools-0.1.1 package from Ivan Dryanovski's github , since it is updated to ONLY the ccny_g2o system rather than the rgbd g2o lib.

I also modified my libg2o file by adding This seems to have sorted out the g2o errors.

Now when I compile the package, this is the error it is throwing up.

ccny_rgbd_tools-0.1.1/ccny_rgbd/src/structures/rgbd_frame.cpp:308:18: error: no match for ‘operator=’ in ‘cloud.pcl::PointCloud<pcl::PointXYZRGB>::header = ((const ccny_rgbd::RGBDFrame*)this)->ccny_rgbd::RGBDFrame::header’

I assume the error above is due to incompatibilty of the PCL system used (probably for groovy and earlier), when I am running ROS-hydro. I have used PCL elsewhere without issues - I even tried manually migrating the ccny_rgbd_tools package to the standalone PCL system, but it is ridiculously complicated,

How do I use the "hydro compatible" ccny_rgbd_tools system, and also utilize the ccny_g2o format of the 0.1.1 edition? I've gone through every other issue / answers posted on the forum about ccny_rgbd, and all compilation errors (for their respective distros) have supposedly been solved by migrating to the 0.1.1 edition, but I haven't been able to solve this. I'd be grateful if anyone could help me out with building this package.

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted

answered 2015-06-02 14:07:34 -0500

Tanmay gravatar image

Hello everyone,

My assumption that the errors were stemming from the distro issues and PCL compatibility were right - ccny_rgbd_tools-0.1.1 is NOT a Hydro release. I switched to the Hydro release (you could also use 0.2.0 or the master branch), and sort out G2O / Suiteparse errors to make this work.

edit flag offensive delete link more

Question Tools

1 follower


Asked: 2015-05-21 16:46:12 -0500

Seen: 150 times

Last updated: Jun 02 '15