Ask Your Question
5

turtlebot apt-get update has generated an error on minimal.launch

asked 2015-05-21 14:26:05 -0500

updated 2015-05-25 12:48:03 -0500

Hi

Just ran apt-get update on a turtlebot install on an odroid C1 (ARM board) running 14.04 and indigo.

robot_state_publihser version is 1.10.4

After the update running minimal.launch I get the rising notes from the turtlebot but output now contains error

odroid@odroid:~$ roslaunch turtlebot_bringup minimal.launch
... logging to /home/odroid/.ros/log/f6f0c208-0052-11e5-a038-001e06c2b101/roslaunch-odroid-1862.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

started roslaunch server http://odroid:57919/

SUMMARY
========

PARAMETERS
 * /app_manager/auto_rapp_installation: False
 * /app_manager/auto_start_rapp: 
 * /app_manager/capability_server_name: capability_server
 * /app_manager/local_remote_controllers_only: False
 * /app_manager/preferred: [{'rocon_apps/chi...
 * /app_manager/rapp_package_blacklist: []
 * /app_manager/rapp_package_whitelist: ['rocon_apps', 't...
 * /app_manager/robot_icon: turtlebot_bringup...
 * /app_manager/robot_name: turtlebot
 * /app_manager/robot_type: turtlebot
 * /app_manager/screen: True
 * /app_manager/simulation: False
 * /bumper2pointcloud/pointcloud_radius: 0.24
 * /capability_server/blacklist: ['std_capabilitie...
 * /capability_server/defaults/kobuki_capabilities/KobukiBringup: kobuki_capabiliti...
 * /capability_server/defaults/kobuki_capabilities/KobukiBumper: kobuki_capabiliti...
 * /capability_server/defaults/kobuki_capabilities/KobukiCliffDetection: kobuki_capabiliti...
 * /capability_server/defaults/kobuki_capabilities/KobukiLED1: kobuki_capabiliti...
 * /capability_server/defaults/kobuki_capabilities/KobukiLED2: kobuki_capabiliti...
 * /capability_server/defaults/kobuki_capabilities/KobukiLED: kobuki_capabiliti...
 * /capability_server/defaults/kobuki_capabilities/KobukiWheelDropDetection: kobuki_capabiliti...
 * /capability_server/defaults/std_capabilities/Diagnostics: turtlebot_capabil...
 * /capability_server/defaults/std_capabilities/DifferentialMobileBase: kobuki_capabiliti...
 * /capability_server/defaults/std_capabilities/LaserSensor: turtlebot_capabil...
 * /capability_server/defaults/std_capabilities/RGBDSensor: turtlebot_capabil...
 * /capability_server/defaults/std_capabilities/RobotStatePublisher: turtlebot_capabil...
 * /capability_server/defaults/turtlebot_capabilities/TurtleBotBringup: turtlebot_capabil...
 * /capability_server/nodelet_manager_name: capability_server...
 * /capability_server/package_whitelist: ['kobuki_capabili...
 * /cmd_vel_mux/yaml_cfg_file: /opt/ros/indigo/s...
 * /description: Kick-ass ROS turtle
 * /diagnostic_aggregator/analyzers/input_ports/contains: ['Digital Input',...
 * /diagnostic_aggregator/analyzers/input_ports/path: Input Ports
 * /diagnostic_aggregator/analyzers/input_ports/remove_prefix: mobile_base_nodel...
 * /diagnostic_aggregator/analyzers/input_ports/timeout: 5.0
 * /diagnostic_aggregator/analyzers/input_ports/type: diagnostic_aggreg...
 * /diagnostic_aggregator/analyzers/kobuki/contains: ['Watchdog', 'Mot...
 * /diagnostic_aggregator/analyzers/kobuki/path: Kobuki
 * /diagnostic_aggregator/analyzers/kobuki/remove_prefix: mobile_base_nodel...
 * /diagnostic_aggregator/analyzers/kobuki/timeout: 5.0
 * /diagnostic_aggregator/analyzers/kobuki/type: diagnostic_aggreg...
 * /diagnostic_aggregator/analyzers/power/contains: ['Battery', 'Lapt...
 * /diagnostic_aggregator/analyzers/power/path: Power System
 * /diagnostic_aggregator/analyzers/power/remove_prefix: mobile_base_nodel...
 * /diagnostic_aggregator/analyzers/power/timeout: 5.0
 * /diagnostic_aggregator/analyzers/power/type: diagnostic_aggreg...
 * /diagnostic_aggregator/analyzers/sensors/contains: ['Cliff Sensor', ...
 * /diagnostic_aggregator/analyzers/sensors/path: Sensors
 * /diagnostic_aggregator/analyzers/sensors/remove_prefix: mobile_base_nodel...
 * /diagnostic_aggregator/analyzers/sensors/timeout: 5.0
 * /diagnostic_aggregator/analyzers/sensors/type: diagnostic_aggreg...
 * /diagnostic_aggregator/base_path: 
 * /diagnostic_aggregator/pub_rate: 1.0
 * /icon: turtlebot_bringup...
 * /interactions/interactions: ['turtlebot_bring...
 * /interactions/pairing: True
 * /interactions/rosbridge_address: localhost
 * /interactions/rosbridge_port: 9090
 * /interactions/webserver_address: webapp.robotconce...
 * /mobile_base/base_frame: base_footprint
 * /mobile_base/battery_capacity: 16.5
 * /mobile_base/battery_dangerous: 13.2
 * /mobile_base/battery_low: 14.0
 * /mobile_base/cmd_vel_timeout: 0.6
 * /mobile_base/device_port: /dev/kobuki
 * /mobile_base/odom_frame: odom
 * /mobile_base/publish_tf: True
 * /mobile_base/use_imu_heading: True
 * /mobile_base/wheel_left_joint_name: wheel_left_joint
 * /mobile_base/wheel_right_joint_name: wheel_right_joint
 * /name: turtlebot
 * /robot/name: turtlebot
 * /robot/type: turtlebot
 * /robot_description: <?xml version="1....
 * /robot_state_publisher/publish_frequency: 5.0
 * /rosdistro: indigo
 * /rosversion: 1.11.13
 * /turtlebot_laptop_battery/acpi_path: /sys/class/power_...
 * /use_sim_time: False
 * /zeroconf/zeroconf/services: [{'domain': 'loca...

NODES
  /zeroconf/
    zeroconf (zeroconf_avahi/zeroconf)
  /
    app_manager (rocon_app_manager/rapp_manager.py)
    bumper2pointcloud (nodelet/nodelet)
    capability_server (capabilities/capability_server)
    cmd_vel_mux (nodelet/nodelet)
    diagnostic_aggregator (diagnostic_aggregator/aggregator_node)
    interactions (rocon_interactions/interactions_manager.py)
    master (rocon_master_info/master.py)
    mobile_base (nodelet/nodelet)
    mobile_base_nodelet_manager (nodelet/nodelet)
    robot_state_publisher (robot_state_publisher/robot_state_publisher)
    turtlebot_laptop_battery (laptop_battery_monitor/laptop_battery.py)

auto-starting new master
process[master]: started with pid [1876]
ROS_MASTER_URI=http://localhost:11311

setting /run_id to f6f0c208-0052-11e5-a038-001e06c2b101
process[rosout-1]: started with pid [1889]
started core service [/rosout]
process[robot_state_publisher-2]: started with pid [1907]
[robot_state_publisher-2] process has died ...
(more)
edit retag flag offensive close merge delete

Comments

Please document the versions of the packages you're running as well as the full console output of what you're running.

tfoote gravatar imagetfoote ( 2015-05-21 18:51:31 -0500 )edit

further info - updated raspberry pi, once updated, same error. On VM machine (not ARM) updated still works

turtlebot packages updated on pi (can't list all in comment) turtlebot, turtlebot-bringup, turtlebot-capabilities, turtlebot-description, turtlebot-teleop

nickw gravatar imagenickw ( 2015-05-22 04:00:09 -0500 )edit

turtlebot-bringup, turtlebot-capabilities, turtlebot-description, turtlebot-teleop are all version 2.3.11

nickw gravatar imagenickw ( 2015-05-22 06:38:42 -0500 )edit

I can confirm it has stopped working on ODROID XU3 as well, I guess it only affects ARM processors. Is there a way to revert to the working version of robot_state_publisher? Need my robot to work real fast

Cubex gravatar imageCubex ( 2015-05-24 19:27:44 -0500 )edit

Can you get a gdb backtrace? tutorial for launching with gdb

tfoote gravatar imagetfoote ( 2015-05-25 03:35:56 -0500 )edit
1

The gdb backtrace resulted in: Using host libthread_db library "/lib/arm-linux-gnueabihf/libthread_db.so.1".

Program received signal SIGBUS, Bus error. 0xb661ac74 in ?? () from /lib/arm-linux-gnueabihf/libpcre.so.3

PS. I'm using robot_state_publisher in my own robot, not turtlebot

Cubex gravatar imageCubex ( 2015-05-28 23:56:22 -0500 )edit

4 Answers

Sort by ยป oldest newest most voted
3

answered 2015-05-30 08:53:17 -0500

I think I have tracked it down - building robot_model from most current source in a workspace stops robot_state_publisher from crashing. Have tried it on a xu3 and a raspberry pi2 and it has worked on both.

edit flag offensive delete link more

Comments

Interesting, thanks for tracking that down. I'll have to take a look at why that makes a difference.

tfoote gravatar imagetfoote ( 2015-05-30 13:52:10 -0500 )edit

weird, I'm still unable to make it work, it always die with error code -7

Cubex gravatar imageCubex ( 2015-06-01 00:25:08 -0500 )edit

I installed dependencies for the workspace as well (rosdep install --from-paths src -i -y), so that may pull in something relevant, and assume you have sourced the setup file after building the workspace? I am just using standard turtlebot install, but haven't tested with actual robot yet

nickw gravatar imagenickw ( 2015-06-01 01:40:21 -0500 )edit

Sorry, quite a newbie here, what do you mean by building robot_model, i assume it's for turtlebot? What if I'm using my own robot model for rviz?

Cubex gravatar imageCubex ( 2015-06-01 02:26:05 -0500 )edit
ahendrix gravatar imageahendrix ( 2015-06-01 02:43:00 -0500 )edit

robot_model build a robot model from the files you have, it is not the robot model of the robot.

nickw gravatar imagenickw ( 2015-06-01 03:10:47 -0500 )edit

Ok, I've tried rebuilding all of them. Now, the error code has changed from -7 to 127 and still died upon launch

EDIT: Nope, still error -7, and when rosrun robot_state_publisher just to check, it returns Bus error.

Cubex gravatar imageCubex ( 2015-06-02 21:44:11 -0500 )edit

I don't know if it's related, but running rviz returns bus error while most people complained about seg fault

Cubex gravatar imageCubex ( 2015-06-02 22:47:11 -0500 )edit
2

answered 2015-09-10 21:26:12 -0500

NStiurca gravatar image

The accepted answer (build robot_state_publisher from source) did NOT work for me on Odroid XU3 using fully upgraded Ubuntu 14.04. For me, the real culprit seems to be the libpcre3 package according to the gdb backtraces.

My workaround is to upgrade the libpcre3 package (and related -dev, -dbg, and libpcrecpp0 packages) with the .deb binaries from Utopic (Ubuntu 14.10).

cd ~/Downloads
wget http://launchpadlibrarian.net/182261128/libpcre3_8.35-3ubuntu1_armhf.deb
wget http://launchpadlibrarian.net/182261132/libpcre3-dev_8.35-3ubuntu1_armhf.deb
wget http://launchpadlibrarian.net/182261135/libpcre3-dbg_8.35-3ubuntu1_armhf.deb
wget http://launchpadlibrarian.net/182261131/libpcrecpp0_8.35-3ubuntu1_armhf.deb
sudo dpkg -i libpcre*8.35*.deb

After this, the robot_state_publisher should run fine, even without compiling it from source.

edit flag offensive delete link more

Comments

@NStiurca That's interesting. There's also a known issue with rviz and pcre on armhf: http://answers.ros.org/question/21231...

It's possible that recompiling from source simply hides the problem with pcre. That could explain the reproducibility.

tfoote gravatar imagetfoote ( 2015-09-10 21:44:49 -0500 )edit

It may be worth filing a bug report with Ubuntu then since 14.04 is LTS. For my part, I dropped a link to this answer in the question you linked.

NStiurca gravatar imageNStiurca ( 2015-09-11 14:21:37 -0500 )edit

Recompiling robot_state_publisher from source didn't work for me either, but recompiling both robot_state_publisher and the robot_model repo from source did work. I'm yet sure that this is just a bug within libpcre

jbinney gravatar imagejbinney ( 2015-09-12 22:08:50 -0500 )edit

looks like the latest release of robot_model removes the direct dependency on libpcre, which looked like it had been added to get round a previous issue.

Compiling the most up to date robot_model from the repo source with these commits was what was working for me, not the 1.11.7 release

nickw gravatar imagenickw ( 2015-09-13 02:25:53 -0500 )edit
1

answered 2015-05-27 18:01:47 -0500

tfoote gravatar image

updated 2015-05-27 18:20:52 -0500

I can confirm that the package ros-indigo-robot-state-publisher_1.10.4-0trusty-20150503-170826-0700_armhf.deb exhibits this problem but the slightly older version does not: ros-indigo-robot-state-publisher_1.10.4-0trusty-20150403-134710-0700_armhf.deb

The crash I get is a segfault -11

[robot_state_publisher-2] process has died [pid 1644, exit code -11, cmd /opt/ros/indigo/lib/robot_state_publisher/robot_state_publisher __name:=robot_state_publisher __log:=/home/linaro/.ros/log/bcc9a036-04c1-11e5-aa48-00037f20a274/robot_state_publisher-2.log].
log file: /home/linaro/.ros/log/bcc9a036-04c1-11e5-aa48-00037f20a274/robot_state_publisher-2*.log

I diffed the files and there's very little difference: Imgur

There's a new version in the pipeline and it has a similar diff: Imgur

Can you try it? http://54.183.65.232/ubuntu/testing/p...

edit flag offensive delete link more

Comments

the link you gave is the new robot state publisher, not the previous version

Cubex gravatar imageCubex ( 2015-05-28 01:40:08 -0500 )edit

still dies for me, probably for the reason above ;)

nickw gravatar imagenickw ( 2015-05-28 03:04:13 -0500 )edit

I tried building robot_state_publisher in a workspace from commit 49bca4e again (had done that previously), and it still crashes (exit code -7, cmd /home/odroid/ros/devel/lib/robot_state_publisher/robot_state_publisher). I think that is as far back as the build you referenced

nickw gravatar imagenickw ( 2015-05-28 03:14:28 -0500 )edit

Here's the old version from before the last update. However I think that the problem is not specifically in this package but possibly an ABI issue with dependencies.

tfoote gravatar imagetfoote ( 2015-05-28 12:19:21 -0500 )edit

ros-shadow-fixed has a newer version of robot_model. please try pulling from there.

tfoote gravatar imagetfoote ( 2015-06-01 14:12:54 -0500 )edit

The newly synced debians have a rebuilt robot_model built on 5/24 which might be worth testing.

tfoote gravatar imagetfoote ( 2015-06-01 14:44:39 -0500 )edit

ros-shadow-fixed is working for me on odroid c1 - will try it on others as well

nickw gravatar imagenickw ( 2015-06-01 14:55:16 -0500 )edit

only worked on that first one - other 3 boards I have tried not fixed - but overlaying workspace still fixes it

nickw gravatar imagenickw ( 2015-06-01 16:37:11 -0500 )edit
0

answered 2015-05-25 23:04:48 -0500

ahendrix gravatar image

Try uninstalling ROS and reinstalling from my old repository at http://packages.namniart.com/repos/ros/

edit flag offensive delete link more

Comments

I have got to a running system doing this, thanks. Should I report the bug anywhere - not sure where to, as its still not clear why it doesn't work, and what is causing the issue

nickw gravatar imagenickw ( 2015-05-26 14:41:36 -0500 )edit

This suggests that the new build farm which is building Indigo debs for ARM has hit a glitch somewhere. This is probably the best place to report bugs, and @tfoote can take a deeper look at it.

ahendrix gravatar imageahendrix ( 2015-05-26 15:07:14 -0500 )edit

I suspect the issue will go away when the new Indigo ARM build farm does a complete rebuild of all of the binaries.

ahendrix gravatar imageahendrix ( 2015-05-26 15:07:38 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

4 followers

Stats

Asked: 2015-05-21 14:26:05 -0500

Seen: 3,410 times

Last updated: Sep 10 '15