Ask Your Question
0

Error trying to "catkin_make" ar_pose package

asked 2015-05-15 12:58:24 -0500

Leandro gravatar image

updated 2015-05-25 08:54:52 -0500

Hello everyone,

I need to read some tags using the kinect. However, even after I installed the dependencies and built the package (commands rosdep install ar_pose -i and rosmake ar_pose), when I try to launch the test:

roslaunch ar_pose ar_pose_single.launch

I receive the following error:

ERROR: cannot launch node of type [ar_pose/ar_single]: can't locate node [ar_single] in package [ar_pose]

I cloned the package from ar_tools and built in my catkin workspace. Can anyone help me? I'm working with ROS Indigo on Ubuntu 14.04.

EDIT1:

Dan, thanks again for your help. I already tried that with no success, I still get the same error when I try to catkin_make. I even erased my build and devel folders to build up my workspace again.

EDIT2:

Dan,

Thanks for your answer. However, I'm still experiencing a problem. When I try to catkin_make install I receive the following error:

Do you know what could be the problem?

Linking CXX executable /home/leandrosavieira/catkin_ws/devel/lib/ar_pose/ar_multi
Linking CXX executable /home/leandrosavieira/catkin_ws/devel/lib/ar_pose/ar_single
CMakeFiles/ar_single.dir/src/ar_single.cpp.o: na função `ar_pose::ARSinglePublisher::getTransformationCallback(boost::shared_ptr<sensor_msgs::Image_<std::allocator<void> > const> const&)':
ar_single.cpp:(.text+0x318d): referência indefinida para `_IplImage::_IplImage(cv::Mat const&)'
CMakeFiles/ar_multi.dir/src/ar_multi.cpp.o: na função `ar_pose::ARMultiPublisher::getTransformationCallback(boost::shared_ptr<sensor_msgs::Image_<std::allocator<void> > const> const&)':
ar_multi.cpp:(.text+0x2569): referência indefinida para `_IplImage::_IplImage(cv::Mat const&)'
collect2: error: ld returned 1 exit status
collect2: error: ld returned 1 exit status
make[2]: ** [/home/leandrosavieira/catkin_ws/devel/lib/ar_pose/ar_single] Erro 1make[2]: 
** [/home/leandrosavieira/catkin_ws/devel/lib/ar_pose/ar_multi] Erro 1
make[1]: ** [ar_tools/ar_pose/CMakeFiles/ar_multi.dir/all] Erro 2
make[1]: ** Esperando que outros processos terminem.
make[1]: ** [ar_tools/ar_pose/CMakeFiles/ar_single.dir/all] Erro 2
make: ** [all] Erro 2
Invoking "make install -j4 -l4" failed

EDIT 3:

I tryed what Dan said but I already had libopencv-dev installed in my computer. Therefore, I'm still with the same problem. However, I never used Opencv before so I don't really know if I have to have anything else installed. Do I need to install it from here.

EDIT 4:

I think I got it right now after building vision_opencv in the catkin_workspace. Opencv was missing in my computer even though I had it in the share folder. It now compiles with no errors. Thanks for all the help Dan and Procópio.

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
1

answered 2015-05-22 02:28:24 -0500

Procópio gravatar image

ar_tools do work under indigo. checking your error it seems you don't have opencv installed. is that the case?

edit flag offensive delete link more

Comments

1

Indeed. I would have expected some of the other upstream dependencies to pull in opencv, but maybe not. @Leandro, can you try adding <build_depend>libopencv-dev</build_depend> to ar_pose's package.xml, rerun rosdep install and try catkin_make again?

Dan Lazewatsky gravatar image Dan Lazewatsky  ( 2015-05-22 10:26:59 -0500 )edit
1

answered 2015-05-15 15:55:41 -0500

ar_tools is a catkin package, and should be built using the catkin instructions. I will update the wiki page to reflect that.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-05-15 12:58:24 -0500

Seen: 1,493 times

Last updated: May 25 '15