Ask Your Question
1

problem with frontier_exploration pkg

asked 2015-05-06 14:15:07 -0500

sobot gravatar image

updated 2015-05-15 16:40:54 -0500

Hi,

I setup frontier_exploration on my Kobuki base with URG-04LX lidar. worked the Clearpath's Husky_Navigation demo tutorial to get to the point of testing autonomous exploration with the frontier_exploration package.

right now every component works good:

  • Gmapping runs and builds a good map of the area,
  • Move_base runs and navigates to a manually set goal,

But the problem that i'm stuck with is that when i add the Marker topic to RVIZ and do a Polygon with the "Publish Point" tool, although i close the Polygn sides, i can NOT get it to accept it and turn Red (as in accepted). it only happens once in every 10 or so attempts, then it asks me to put a start off point. i do that and my robot goes to that very point i put and stays there.

my tf tree is good, i got great odometry, map lines are all aligned. /explore_serve and /explore_client nodes are also checked active.

EDIT: here is a picture of my nodes/topics: image description

any help, ideas or suggestions to further reconfigure the settings are more than welcomed...!

EDIT2:

Explorer Launch file:

    <launch>

  <node pkg="frontier_exploration" type="explore_client" name="explore_client" output="screen"/>


  <node pkg="frontier_exploration" type="explore_server" name="explore_server" output="screen">

    <param name="frequency" value="1.0"/>

    <!-- Should be less than sensor range -->
    <param name="goal_aliasing" value="2.0"/>

    <rosparam file="$(find husky_navigation)/config/costmap_common.yaml" command="load" ns="explore_costmap" />
    <rosparam file="$(find husky_navigation)/config/costmap_exploration.yaml" command="load" ns="explore_costmap" />
    <remap from="/base_link" to="/base_footprint" />

  </node>

</launch>

costmap_common.yaml :

footprint: [[-0.125, -0.125], [-0.125, 0.125], [0.125, 0.125], [0.125, 0.0], [0.125, -0.125]]
robot_radius: 0.2
#footprint: [[-0.5, -0.33], [-0.5, 0.33], [0.5, 0.33], [0.5, -0.33]]
footprint_padding: 0.01

robot_base_frame: base_footprint
update_frequency: 4.0
publish_frequency: 3.0
transform_tolerance: 0.5

resolution: 0.05

obstacle_range: 3.0
raytrace_range: 4.0

#layer definitions
static:
    map_topic: /map
    subscribe_to_updates: true

obstacles_laser:
    observation_sources: laser
    laser: {data_type: LaserScan, clearing: true, marking: true, topic: scan, inf_is_valid: true}

inflation:
    inflation_radius: 0.25

costmap_exploration.yaml :

track_unknown_space: true
global_frame: map
rolling_window: false

plugins: 
- {name: external,            type: "costmap_2d::StaticLayer"}
- {name: explore_boundary,    type: "frontier_exploration::BoundedExploreLayer"}
#Can disable sensor layer if gmapping is fast enough to update scans
- {name: obstacles_laser,     type: "costmap_2d::ObstacleLayer"}
- {name: inflation,           type: "costmap_2d::InflationLayer"}

explore_boundary:
  resize_to_boundary: true
  frontier_travel_point: middle
  #set to false for gmapping, true if re-exploring a known area
  explore_clear_space: false

PS: i downloaded the husky_navigation package to try frontier exploration out, used its provided materials and edited them to fit my robots specifications. with the same setup (with the same config files) gmapping and move_base navigation work flawlessly.

EDIT: as per dear "pbovbel" instructions i upgraded the package to a newer version (shadow repo) and the Polygon issue seems gone for the moment (pretty nice!) but the other issue still kind of remains; when setting the "initial point" robot only clears the area that is around it (as seen in the picture below) it leaves some ... (more)

edit retag flag offensive close merge delete

Comments

Were you able to edit the launch files to get the robot to explore the whole space? I have tried reducing inflation radius as paulbovbel suggested, however the robot does not explore the complete space in the polygon boundary.Any help from you would be deeply appreciated.

RS gravatar imageRS ( 2015-07-28 00:37:52 -0500 )edit

@RS Unfortunately i was not able to do that.

sobot gravatar imagesobot ( 2015-08-24 16:07:32 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2015-05-14 13:50:28 -0500

paulbovbel gravatar image

updated 2015-05-15 15:26:59 -0500

An older version of frontier_exploration was having issues with closing the polygon. As of version 0.2.5, the polygon-close-snapping should be much more consistent.

Your topic connections look fine, but there's not really sufficient information here to try to figure out why your setup isn't working. Does the Husky frontier_exploration demo work for you? http://wiki.ros.org/husky_navigation/...

If so, you'll need to investigate your robot configuration to find the problem.


1) What version of frontier exploration do you have installed (dpkg -s ros-indigo-frontier-exploration )?

2) Does adding ROS Shadow repose, and dist-upgrading your packages help? ( http://wiki.ros.org/ShadowRepository )

3) Does cloning frontier_exploration into your workspace and running it from source help?

edit flag offensive delete link more

Comments

Hi Paul, for this I downloaded husky_demo & modified the launch file to fit my robot specs. I just put more info here and also I can provide you with ANY specific information that matters for the exploration pkg. i'd be grateful if you could point me to where i should investigate. Gmapping/Nav work.

sobot gravatar imagesobot ( 2015-05-14 18:06:27 -0500 )edit

To clarify, the Husky exploration demo works as expected?

paulbovbel gravatar imagepaulbovbel ( 2015-05-15 12:00:59 -0500 )edit

@pbovbel i downloaded the husky_gazebo and husky_desktop pkg to test the demo and unfortunately it behaves the same as i experience with my kobuki base. i removed and reinstalled the navigation and explorer packages again, just in case.

sobot gravatar imagesobot ( 2015-05-15 15:04:34 -0500 )edit

@pbovbel i just upgraded the package from Shadow Repo, polygon works, robot moves but as EDITED the question above with a picture, Exploration process leaves unexplored area behind and confirms the "exploration is done" in the terminal. thank you for your time!

sobot gravatar imagesobot ( 2015-05-15 16:43:29 -0500 )edit

Check the visualization of the exploration costmap. It may be that inflation causes that area to be impassible - the frontier search only passes through completely clear cells. You can reduce the inflation radius to allow it to pass through narrower areas.

paulbovbel gravatar imagepaulbovbel ( 2015-05-18 09:44:54 -0500 )edit

now, don't have access to my robot but when i manually set a goal inside that unexplored room, my robot successfully navigates and drives to that area without any problem (with the same setup as Frontier_exp). just a thought, does different laser MaxRange have anything to do with the way pkg works?

sobot gravatar imagesobot ( 2015-05-18 10:08:13 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-05-06 14:15:07 -0500

Seen: 1,143 times

Last updated: May 15 '15