ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Problem about using turtlebot_arm with "pincher" argument

asked 2015-04-30 02:57:53 -0500

Yantian_Zha gravatar image

Hi all,

I'm using ROS indigo with Ubuntu 13.10, and the phantomx pincher arm. The arbotix version is the newest one (for indigo).

Following this link "", I add something like "arm_type:=pincher" after my command. For example: roslaunch turtlebot_arm_moveit_config turtlebot_arm_moveit.launch sim:=false arm_type:=pincher --screen

The good thing is: I got the phantomx pincher model in RViz. But I also got these errors:

image description

And the planning process was always failed:

image description

Also, noting that the arm.launch file mentions that it's could be problematic to directly pass the "pincher" arg, I also tried changing the argument in the launch file, and the outcome didn't change (I got the same errors). Could someone get me out of this problem? thanks!

edit retag flag offensive close merge delete


Hi, if you can see the pitcher arm properly I suppose you are using this fork of the code, right? The pitcher arm stuff is not released still

jorge gravatar image jorge  ( 2015-04-30 09:38:57 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2015-04-30 13:23:38 -0500

corb gravatar image

updated 2015-04-30 19:37:33 -0500

For the PhantomX Pincher arm, you will need to use these:

Arbotix fork:

Turtlebot_arm fork: (as mentioned by Jorge, above)

I think you can't pass the arm type as a parameter as you did above. You need to set environment variable "TURTLEBOT_ARM1" to pincher.

edit flag offensive delete link more


Thanks for your advice. I replaced my packages with yours. And I changed the argument "pincher" in the launch file. But I still got these errors. Perhaps my way of setting environment variable "TURTLEBOT_ARM1" is wrong? Thanks for your further help!

Yantian_Zha gravatar image Yantian_Zha  ( 2015-05-01 04:28:14 -0500 )edit

you shouldnt need to change any of the launch files. you should do the following before you launch:

export TURTLEBOT_ARM1=pincher
corb gravatar image corb  ( 2015-05-01 06:06:19 -0500 )edit

Thanks! I solved it.

Yantian_Zha gravatar image Yantian_Zha  ( 2015-05-03 20:19:34 -0500 )edit

Question Tools

1 follower


Asked: 2015-04-30 02:57:53 -0500

Seen: 232 times

Last updated: Apr 30 '15