ROS Android applications are not working

asked 2015-04-29 02:49:06 -0500

yigit gravatar image

updated 2015-04-30 10:16:37 -0500

Hello everyone,

I created a ROS Android application and run it on my phone without running into any problems. When I tried it on the tablet on my robot, however, I got the following error:

org.ros.exception.RosMessageRuntimeException: java.lang.ClassNotFoundException: Didn't find class "std_msgs.uint32" on path: DexPathList[[zip file "/data/app/boun.tg.avatar-1.apk"],nativeLibraryDirectories=[/data/app-lib/boun.tg.avatar-1, /vendor/lib, /system/lib]]

Then, I got suspicious and installed the Teleop application from Yujin Robotics, from Play store. I had the same error on the tablet and no errors on my phone.

What might be the problem with the tablet? I have a hunch that, there exists a library on my phone - which doesn't on the tablet - that provided std_msgs.uint32 class, which seems quite strange because I couldn't see any relevant libraries on the provided paths on neither my phone nor the tablet.

Can any of you make some comments, please?

Thanks in advance.

edit retag flag offensive close merge delete

Comments

1

Very odd error. I'm afraid I don't really have any leads for you except to say that the message code gets bundled with each application (i.e. not as a separate library). Are the versions of android on phone and tablet different?

Daniel Stonier gravatar imageDaniel Stonier ( 2015-05-01 21:22:35 -0500 )edit

Yes, they are. I actually tried it with more than two devices. On my second tablet it works, as well. It works fine on Android 4.1 and 5.1. The version of the Android, the application is expected to run (but it doesn't) is 4.4.2.

yigit gravatar imageyigit ( 2015-05-02 08:51:49 -0500 )edit

I just tried it with two different devices. Only on Samsung devices, I ran into this problem. On others, it works as expected.

yigit gravatar imageyigit ( 2015-05-02 09:18:58 -0500 )edit

UPDATE: I am 99% sure that the problem is persistent on Samsung devices. I have been trying the Teleop app on all the Samsung devices I can get my hands on but I haven't been able to see it running smoothly. On other devices, however, regardless of the version of the Android, it works fine.

yigit gravatar imageyigit ( 2015-05-03 19:16:48 -0500 )edit

i am also encountered same problem. Have you made any progress on the problem? @yigit

brkygkcn gravatar imagebrkygkcn ( 2017-05-28 17:50:44 -0500 )edit