Ask Your Question
0

URDF files can not work on rviz ( ERROR on terminal )

asked 2015-04-27 01:51:02 -0500

Atilay Mayadag gravatar image

updated 2015-04-27 02:02:38 -0500

gvdhoorn gravatar image

Hello Everyone, I am following ROS/ Tutorials and I came aorund URDF Tutorials but relevant both URDF and XACRO examples I couldnt run , I couldnt stimulate on rviz. After all Trying and all searching to answer what is problem, I found myself here so ; Could you lead me ? when I command

roslaunch urdf_tutorial display.launch model:=urdf/03-origins.urdf  
roslaunch urdf_tutorial display.launch model:=urdf/05-visual.urdf
$ check_urdf my_robot.urdf
$ urdf_to_graphiz my_robot.urdf
$ evince test_robot.pdf

there is the error saying like this:

atilay@atilayLnxPC:/opt/ros/indigo$
roslaunch urdf_tutorial display.launch
model:=urdf/03-origins.urdf ...
logging to /home/atilay/.ros/log/4963afa4-ec9f-11e4-8c36-00231518f52c/roslaunch-atilayLnxPC-7548.log
Checking log directory for disk usage. This may take awhile. Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

Traceback (most recent call last):  
File "/opt/ros/indigo/lib/python2.7/dist-packages/roslaunch/__init__.py",
line 298, in main
    p.start()   File "/opt/ros/indigo/lib/python2.7/dist-packages/roslaunch/parent.py",
line 260, in start
    self._start_infrastructure()   File
"/opt/ros/indigo/lib/python2.7/dist-packages/roslaunch/parent.py",
line 209, in _start_infrastructure
    self._load_config()   File "/opt/ros/indigo/lib/python2.7/dist-packages/roslaunch/parent.py",
line 124, in _load_config
    roslaunch_strs=self.roslaunch_strs,
verbose=self.verbose)   File
"/opt/ros/indigo/lib/python2.7/dist-packages/roslaunch/config.py",
line 451, in load_config_default
    loader.load(f, config, verbose=verbose)   File
"/opt/ros/indigo/lib/python2.7/dist-packages/roslaunch/xmlloader.py",
line 730, in load
    self._load_launch(launch, ros_config, is_core=core,
filename=filename, argv=argv,
verbose=verbose)   File
"/opt/ros/indigo/lib/python2.7/dist-packages/roslaunch/xmlloader.py",
line 702, in _load_launch
    self._recurse_load(ros_config, launch.childNodes, self.root_context,
None, is_core, verbose)   File
"/opt/ros/indigo/lib/python2.7/dist-packages/roslaunch/xmlloader.py",
line 646, in _recurse_load
    self._param_tag(tag, context, ros_config, verbose=verbose)   File
"/opt/ros/indigo/lib/python2.7/dist-packages/roslaunch/xmlloader.py",
line 95, in call
    return f(*args, **kwds)   File "/opt/ros/indigo/lib/python2.7/dist-packages/roslaunch/xmlloader.py",
line 264, in _param_tag
    value = self.param_value(verbose, name, ptype, *vals)   File
"/opt/ros/indigo/lib/python2.7/dist-packages/roslaunch/loader.py",
line 463, in param_value
    with open(textfile, 'r') as f:
**IOError: [Errno 2] No such file or directory: u'urdf/03-origins.urdf'**

My idea is that this error occurs related with urdf , urdf_parser_plugin and liburdfdom-tools .. I searched that liburdfdom-tools is old and not related with ROS but I have been installed that and I couldnt fix it.. there is the time important for develop the robot for my Thesis lead me please.. what can I do for fix it ? by the way I use ROS / indigo

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2015-04-27 02:05:44 -0500

gvdhoorn gravatar image

updated 2015-04-27 02:07:09 -0500

The error tells you that urdf/03-origins.udf cannot be found. If the file does exist, it's likely that you forgot to execute those commands in the correct working directory.

See Error in Building a Visual Robot Model with URDF from Scratch and / or No Visual Robot Model with URDF.

edit flag offensive delete link more

Comments

is it true tick ? and thank you for answering , and sorry for my fault about forum

Atilay Mayadag gravatar imageAtilay Mayadag ( 2015-04-27 18:46:05 -0500 )edit

No problem.

gvdhoorn gravatar imagegvdhoorn ( 2015-04-27 22:56:49 -0500 )edit
0

answered 2015-04-27 12:03:04 -0500

Atilay Mayadag gravatar image

updated 2015-04-27 12:05:18 -0500

thank you , I run the project with the solution what is in the link you shared.
but following forward tutorials, I had problem about xacro examples . however i downloaded with

git clone LINK

(pr2_common packkage) but i couldnt run this command

> rosdep install pr2_comman

or

> rosdep install pr2_description

so there is

atilay@atilayLnxPC:~$ rosdep install pr2_common

ERROR: Rosdep cannot find all required resources to answer your query Missing resource pr2_common ROS path [0]=/opt/ros/indigo/share/ros ROS path [1]=/opt/ros/indigo/share ROS path [2]=/opt/ros/indigo/stacks

what should I do ?

and the another question is that How i can reinstall ROS/indigoo or uninstal and install agin it ?

edit flag offensive delete link more

Comments

If your issue was solved, please mark the question as solved by clicking the tick mark next to the answer. As to your other questions: uninstal ros and reinstall again. Open a new one for the pr2_common questions.

gvdhoorn gravatar imagegvdhoorn ( 2015-04-27 12:29:52 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-04-27 01:51:02 -0500

Seen: 826 times

Last updated: Apr 27 '15