Ask Your Question
1

rospkg.manifest.InvalidManifest

asked 2015-04-24 11:18:11 -0600

sunny2015 gravatar image

updated 2015-04-25 03:35:50 -0600

130s gravatar image

when I run roscore,the output is like below,how can I solve this problem?

WARNING: unable to configure logging. No log files will be generated
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

Traceback (most recent call last):
  File "/opt/ros/fuerte/bin/rosversion", line 5, in <module>
    pkg_resources.run_script('rospkg==1.0.2', 'rosversion')
  File "/usr/lib/python2.7/dist-packages/pkg_resources.py", line 499, in run_script
    self.require(requires)[0].run_script(script_name, ns)
  File "/usr/lib/python2.7/dist-packages/pkg_resources.py", line 1235, in run_script
    execfile(script_filename, namespace, namespace)
  File "/usr/local/lib/python2.7/dist-packages/rospkg-1.0.2-py2.7.egg/EGG-INFO/scripts/rosversion", line 76, in <module>
    version = rosstack.get_stack_version(stack_name)
  File "/usr/local/lib/python2.7/dist-packages/rospkg-1.0.2-py2.7.egg/rospkg/rospack.py", line 359, in get_stack_version
    return get_stack_version_by_dir(self.get_path(stack))
  File "/usr/local/lib/python2.7/dist-packages/rospkg-1.0.2-py2.7.egg/rospkg/rospack.py", line 412, in get_stack_version_by_dir
    m = parse_manifest_file(stack_dir, STACK_FILE)
  File "/usr/local/lib/python2.7/dist-packages/rospkg-1.0.2-py2.7.egg/rospkg/manifest.py", line 343, in parse_manifest_file
    return parse_manifest(manifest_name, f.read(), filename)
  File "/usr/local/lib/python2.7/dist-packages/rospkg-1.0.2-py2.7.egg/rospkg/manifest.py", line 404, in parse_manifest
    m.author = _check('author')(p, filename)
  File "/usr/local/lib/python2.7/dist-packages/rospkg-1.0.2-py2.7.egg/rospkg/manifest.py", line 67, in check
    raise InvalidManifest("Invalid manifest file [%s]: must have a single '%s' element"%(filename, name))
rospkg.manifest.InvalidManifest: Invalid manifest file [/opt/ros/fuerte/share/ros/stack.xml]: must have a single 'author' element
Invalid <param> tag: Cannot load command parameter [rosversion]: command [rosversion ros] returned with code [1]. 

Param xml is <param command="rosversion ros" name="rosversion"/>
edit retag flag offensive close merge delete

Comments

some more or better info, what commands did you run to install? what os, which ros version, etc, etc,

inflo gravatar imageinflo ( 2015-04-24 11:22:53 -0600 )edit

Fuerte and Ubuntu 12.04 (Precise)

sunny2015 gravatar imagesunny2015 ( 2015-04-24 11:36:34 -0600 )edit

I run : sudo apt-get install ros-fuerte-desktop-full to install fuerte

sunny2015 gravatar imagesunny2015 ( 2015-04-24 11:41:10 -0600 )edit

sorry, dont know, try to remove and re-install again

inflo gravatar imageinflo ( 2015-04-24 12:53:50 -0600 )edit

how to remove the ros? sorry, I am a beginner

sunny2015 gravatar imagesunny2015 ( 2015-04-24 13:21:00 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2015-04-25 03:39:15 -0600

tfoote gravatar image

You are running a very old version of rospkg. The last verion released is 1.0.35 your traceback indicates 1.0.2 which was released in April 2012.

Also from your trackback I can see it's located in /usr/local/lib which is indicative of a pip/easy_install based installation. You should make sure to uninstall that copy which will mask out the newer version from the debian packages. To see how to uninstall via pip you can get instructions here

To see what version you're running check that you get something like the following.

$ dpkg -l | grep rospkg
ii  python-rospkg                                         1.0.35-1                                            all          ROS package library
$ pip freeze | grep rospkg
rospkg==1.0.35
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-04-24 11:18:11 -0600

Seen: 1,533 times

Last updated: Apr 25 '15