Ask Your Question
0

rviz not clearing point or depth clouds with decay time of 0

asked 2015-04-14 16:31:14 -0600

Tom Moore gravatar image

updated 2015-04-14 16:32:22 -0600

My issue

I'm having trouble displaying point and depth clouds within rviz. Specifically, no matter what value I set for the decay time, the point clouds continue to aggregate endlessly. After only a few seconds, this causes rviz to become completely unresponsive.

My setup

  • I'm using an ASUS Xtion Pro Live
  • I'm using rviz for ROS Indigo, obtained from the package servers (not compiled from source)
  • Likewise, I am using the packaged versions of all openni-related packages
  • I have an NVIDIA NVS 5200M (Dell Latitude E6530)

Other Notes

  • I also managed to replicate the behavior using a compiled-from-source version under OS X
  • I am subscribing to /camera/depth_registered/points (a PointCloud2 message), but the same issue occurs with the /camera/depth_registered/image_raw topic when I display a DepthCloud.
  • I've tried several other decay times, but the result is always the same

Apologies in advance if I'm missing something obvious.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
2

answered 2015-06-17 00:05:48 -0600

Daniel Stonier gravatar image

updated 2015-06-17 00:09:28 -0600

This can happen if there is no clock information being published and rviz has no reference for what is the latest. It is debatable whether it actually needs the clock since it could just refer to message timestamps, but at any rate this is how it currently works (I'd be curious if someone has an answer to this).

You can check that time is moving in rviz in the bottom left corner. If you are having this problem running rosbag, make sure you are using --clock with the command. If you are warping through a bag, you have to publish the clock yourself. If it's a robot, then perhaps your robot is having problems publishing time.

If you're not bagging, then it might be a difference in time on the two computers causing problems. Use chrony to sync them.

edit flag offensive delete link more

Comments

It was indeed a time issue. The time server was running (rosbag was running with --clock and use_sim_time was true, as my software also requires the time server), but the time stamps in my depth cloud were incorrect. Duh. Thanks!

Tom Moore gravatar imageTom Moore ( 2015-06-17 08:50:10 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

3 followers

Stats

Asked: 2015-04-14 16:31:14 -0600

Seen: 1,215 times

Last updated: Jun 17 '15