Ask Your Question
0

roslaunch stuck on 'Loading robot model'

asked 2015-04-13 16:31:08 -0500

aak2166 gravatar image

Hi all.

I'm trying to run a moveit path that I have planned out with the following launch file:

<launch>
    <arg name="urdf_file" default="$(find planar_2d_description)/urdf/planar_2d.urdf" />
    <arg name="srdf_file" default="$(find planar_2d_config)/config/planar_2d.srdf" />
    <param name="robot_description" command="cat $(arg urdf_file)" />
    <param name="robot_description_semantic" command="cat $(arg srdf_file)" />
    <include file="$(find planar_2d_config)/launch/planar_2d_moveit_controller_manager.launch.xml"/>
    <node
        pkg="planar_2d_planning"
        type="project_part_one"
        name="planning_node"
        output="screen"
    />
</launch>

However, on launch ROS seems to hang up at this step:

[ INFO] [1428960470.895442847]: Loading robot model 'planar_2d'...

And if I kill it with ctrl+C:

terminate called after throwing an instance of 'std::runtime_error' what(): Unable to connect to move_group action server within allotted time (2)

I'm at a loss as to what can be causing this. The paths to my urdf and srdf are correct, and I am passing the param the contents of the file with cat, not just the path.

If anyone has any ideas it would be greatly appreciated. Thanks.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2015-04-15 04:06:49 -0500

gvdhoorn gravatar image

updated 2015-04-15 04:07:28 -0500

<include file="$(find planar_2d_config)/launch/planar_2d_moveit_controller_manager.launch.xml"/>

That include is not enough to start MoveIt correctly, which is why you get the Unable to connect to move_group action server within allotted time (2) error. Not all services have been started which hangs your application: it is simply waiting for those services to come up.

Do you have any specific reason to want to create this all by hand? The moveit_setup_assistant creates a demo.launch file for you which starts and configures all the required nodes for a functioning planning pipeline. Take a look at the demo.launch from the pr2_moveit_config package to see an example (but your planar_2d_config should also have one).

As an immediate fix, you could include the move_group.launch file from your planar_2d_config package, instead of what you're doing now. Use demo.launch to see which parameters it needs (here for the PR2 again).

edit flag offensive delete link more

Comments

I used the setup assistant to create my config files. Then I had to change a few of them, since I have a 2 DOF arm and am using a custom ik solver. I managed to get it to work by including the planning_context file with the load_robot_description value set to true.

aak2166 gravatar image aak2166  ( 2015-04-15 06:11:41 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-04-13 16:31:08 -0500

Seen: 1,645 times

Last updated: Apr 15 '15