ROS Resources: Documentation | Support | Discussion Forum | Service Status | Q&A answers.ros.org
Ask Your Question
0

Unable to view camera output while using cv_bridge

asked 2015-04-09 13:06:17 -0500

Anand gravatar image

updated 2015-04-24 11:10:45 -0500

I am using ROS Hydro in Ubuntu 12.04 which is installed in Virtualbox. I am trying to use cv_bridge to convert my ros images to opencv images captured by Logitech C270.

Being a novice to this field, I am following the tutorial explained on this blog : link .

All works fine but still I am not able to see the camera output, rather the complete output screen appears green.

Same is the case while following the ROS tutorial, given on the link : link

Guys I am in need of help...please help me...!!!

edit retag flag offensive close merge delete

Comments

some more or better info, like, what commands are you running to see an image? can you normaly see the image?etc. etc.

inflo gravatar imageinflo ( 2015-04-24 11:20:22 -0500 )edit

Firstly thanks for your reply. Yes sure. Initially I am using the command - roslaunch uvcCameraLaunch.launch ... this works fine and my camera gets light up. After that i am running the command - rosrun image_view image_view image:=/camera/image_raw.. this pops up a window named /camera/image_raw

Anand gravatar imageAnand ( 2015-04-24 11:51:58 -0500 )edit

This window /camera/image_raw has the screen which is completely green rather than seeing the display of camera.

Anand gravatar imageAnand ( 2015-04-24 11:54:01 -0500 )edit

check with "rostopic list" after uvcCameraLaunch.launch which image topics also exist and try another with "rosrun image_viewer..."

else could you see with a simply webcam app a normal picture or also a green one ?

inflo gravatar imageinflo ( 2015-04-24 12:51:42 -0500 )edit

Yes i am able to view properly the webcam output with webcam app. The output of rostopic list is: /camera/camera_info
/camera/image_raw
/rosout
/rosout_agg

Anand gravatar imageAnand ( 2015-04-24 13:07:07 -0500 )edit

the page http://wiki.ros.org/uvc_camera says that one should use http://wiki.ros.org/libuvc_camera , tried that?

inflo gravatar imageinflo ( 2015-04-24 13:27:29 -0500 )edit

OH thank you very much for giving me an idea that there might be some issue with package. The uvc_camera package was having some problem. So i used the package usb_cam and it worked.

Anand gravatar imageAnand ( 2015-04-24 14:59:19 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2015-04-24 15:00:11 -0500

Anand gravatar image

Use package usb_cam instead of uvc_camera.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-04-09 13:06:17 -0500

Seen: 365 times

Last updated: Apr 24 '15