ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question
2

Permission Denied

asked 2015-04-06 22:13:58 -0500

Joelac0193 gravatar image

updated 2015-04-07 03:05:11 -0500

gvdhoorn gravatar image

I am on Ubuntu 10.04 and I have ROS Electric installed. I am following these instructions and I am on Step 3 (Generating the URDF): http://wiki.ros.org/nxt_lxf2urdf/Tuto...

When I input the command rosrun nxt_lxf2urdf lxf2urdf.py robot.lxf robot.ldr >robot.urdf I get:

[rospack] WARNING: cannot create rospack cache directory: Permission denied
[rospack] WARNING: cannot create rospack cache directory: Permission denied
[rospack] Unable to create temporary cache file /root/.ros/.rospack_cache.cSxwgs: Permission denied

What to do? I am fairly new to Ubuntu and ROS.

edit retag flag offensive close merge delete

Comments

1

The error seems to suggest you once ran things as the root user ("[..] file /root/.ros/.."). Can you think of a reason why that would be the case? Your normal user does not have access to that directory, but a typical ROS installation wouldn't need a dir in /root/ either.

gvdhoorn gravatar image gvdhoorn  ( 2015-04-07 03:05:37 -0500 )edit

Well whenever I do anything in the terminal I always input this command: sudo -i

Joelac0193 gravatar image Joelac0193  ( 2015-04-07 07:36:35 -0500 )edit

Nevermind I got it. I input the command sudo -s and it worked. Thanks

Joelac0193 gravatar image Joelac0193  ( 2015-04-07 07:40:57 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2015-04-07 07:54:12 -0500

gvdhoorn gravatar image

Well whenever I do anything in the terminal I always input this command: sudo -i

Why do you use sudo? A normal ROS installation shouldn't need it?

If you need it to access (serial) devices, please see Rosrun as super user.

edit flag offensive delete link more

Comments

I have the same issue. I believe the problem is due to having a different partition for /home during installation of ubuntu. sudo gives the right permissions to make any file edits. There should be a work around, but I have not yet figured it out. Any ideas?

gkbot gravatar image gkbot  ( 2018-02-14 06:56:34 -0500 )edit

Your own user should be able to access its own files. If not, that is a system configuration issue, and should be fixed. That would seem to be something not related to ROS, so I would suggest asking it over at Ask Ubuntu or a similar forum.

gvdhoorn gravatar image gvdhoorn  ( 2018-02-14 07:01:45 -0500 )edit
3

You can try rosdep fix-permissions as a workaround, it worked for me

DavidGuitarMetal gravatar image DavidGuitarMetal  ( 2018-05-08 02:07:12 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2015-04-06 22:13:58 -0500

Seen: 9,497 times

Last updated: Apr 07 '15