Ask Your Question
1

Raspbian ROS Indigo - Rosserial_xbee error

asked 2015-03-31 16:09:27 -0500

rip24 gravatar image

updated 2015-04-01 06:51:00 -0500

Hello, I've been trying out the Xbee network tutorial from the wiki: http://wiki.ros.org/rosserial_xbee/Tu...

My setup: Raspberry Pi with Xbee Series 1 and Arduino Uno with Wireless SD shield that has a Xbee Series 1 on top of that.

I have configured the Xbee's with XCTU and the xbee is connected to the AMA0 port

When I try to run the command: rosrun rosserial_xbee xbee_network.py /dev/ttyAMA0 1 I can see the Arduino flashing as if it is sending the data. When i open Arduino's port monitor i can also see that it is sending the data. So i guess the Xbee connection isn't the problem here?

I get the following error:

Traceback (most recent call last): 
File "/usr/lib/python2.7/threading.py", line 552, in __bootstrap_inner
   self.run()
File "/usr/lib/python2.7/threading.py", line 505, in run 
   self.__target(*self.__args, **self.__kwargs)
File "/home/pi/catkin_ws/src/rosserial/rosserial_python/src/rosserial_python/SerialClient.py", line 434, in run 
   if self.port.inWaiting() < 1:
AttributeError: FakeSerial instance has no attribute 'inWaiting'

I found only one other person struggling with the same problem here; http://answers.ros.org/question/18744... But no obvious fix was found? The marked answer suggests that installing ROS hydro rosserial fixes the problem. Can that actually work?

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2015-04-03 12:01:40 -0500

rmolin88 gravatar image

updated 2015-07-24 14:13:25 -0500

I posted an issue on the github rosserial site

I have marked the Issue resolved Please visit the link above to see the solution.

edit flag offensive delete link more

Comments

1

Thanks for the info, atleast now i know that this is an issue for everyone =)

rip24 gravatar image rip24  ( 2015-04-03 12:49:19 -0500 )edit
0

answered 2015-04-05 15:25:11 -0500

rip24 gravatar image

updated 2015-04-07 14:12:27 -0500

I found a temporary solution for my problem! I tested different versions/tags (whichever is the right terminology) of the Rosserial git and I found out that the problem was introduced in version/tag 0.5.6. So for now I guess I will use 0.5.5, which works nicely with the xbee.

EDIT: It turns out I came across a lucky bug, because when I tried to do the same again on my other ROS copy, it did not work. Really hope this issue gets fixed soon!

edit flag offensive delete link more

Comments

hi, could you please describe the steps in detail to downgrade the rosserial version. That should work because on the answer posted the author said: "The bug would have been introduced in 370f579".

rmolin88 gravatar image rmolin88  ( 2015-04-07 22:59:41 -0500 )edit

To downgrade rosserial, you need to first go into your rosserial git directory and enter: git checkout CommitCode. For example: git checkout ba83ced96c

After that, you can just go back to your workspace dir and enter the usual commands: catkin_make and after that catkin_make install

rip24 gravatar image rip24  ( 2015-04-08 10:31:29 -0500 )edit

Oh and you can get the commit codes from the rossserial github site: https://github.com/ros-drivers/rosserial

git checkout ba83ced96c is for example rosserial 0.5.5

rip24 gravatar image rip24  ( 2015-04-08 10:34:50 -0500 )edit

The correct fix should be to add an inWaiting method to xbee_network.py. Just like the author said. But I don't have enough knowledge on how that script works or what the method should contain.

rip24 gravatar image rip24  ( 2015-04-08 10:52:35 -0500 )edit

I know I look into it also, but it's not an option for me at the moment. Have to deliver my project soon lol. I'll look at it afterwards. @rip24 when you say "go into your rosserial git directory" do you mean /opt/ros/indingo/share/rosserial??

rmolin88 gravatar image rmolin88  ( 2015-04-08 11:13:44 -0500 )edit

By the git directory, i mean the location where you downloaded the rosserial git with the command git clone . git clone downloads the ENTIRE library, so all the versions are already in there, you just need to tell it to install some other version.

My dir for example: ~/catkin_ws/src/rosserial

rip24 gravatar image rip24  ( 2015-04-08 12:04:46 -0500 )edit

I am too facing this issue. has anybody solved it ? if yes, then please provide the solution. Thanks in advance

darshandoria gravatar image darshandoria  ( 2016-05-26 00:06:54 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2015-03-31 16:09:27 -0500

Seen: 464 times

Last updated: Jul 24 '15