Ask Your Question
0

Warning with ompl [closed]

asked 2015-03-30 03:54:21 -0500

pexison gravatar image

Hello,

I have updated my ros packages, now when I use catkin_make or run certain nodes, I obtain:

WARNING: Package "ompl" does not follow the version conventions. It should not contain leading zeros (unless the number is 0).

There is a way to fix this warning?

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by pexison
close date 2015-03-30 04:18:04.599808

1 Answer

Sort by ยป oldest newest most voted
1

answered 2015-03-30 03:58:54 -0500

gvdhoorn gravatar image

That warning is really just a warning, and has no influence on the correct functioning of OMPL, MoveIt or any package/node making use of it.

See also @isucan's answer in Package "ompl" does not follow the version conventions:

For historical reasons, the convention for the OMPL version is non-standard: https://github.com/ros-gbp/ompl-relea...

This was done so that we have unique version numbers and can release OMPL for ROS outside of the regular OMPL release cycle. In the meantime things have stabilized much more, so I think we could start adopting a standard version. That said, we should probably switch to the debian package for OMPL directly (although, even for indigo, that is a bit old now).

edit flag offensive delete link more

Comments

Thanks! Like it says in the Answer of the link that you posted, "Try linking against ${OMPL_LIBRARIES} instead of ${ompl_LIBRARIES}" solved the problem.

pexison gravatar imagepexison ( 2015-03-30 04:17:33 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2015-03-30 03:54:21 -0500

Seen: 736 times

Last updated: Mar 30 '15