Ask Your Question
1

razor_imu_9dof on ROS Indigo - ImportError: No module named cfg

asked 2015-03-26 11:58:30 -0500

Hi !

I'm trying to get the razor_imu_9dof node working on ROS Indigo and Ubuntu 14.04. It is well detected on ttyUSB0 and I can see the data flow with gtkterm.

I installed the package from the repository. When I run

roslaunch razor_imu_9dof razor-pub.launch

I got an error saying :

Traceback (most recent call last):
  File "/opt/ros/indigo/share/razor_imu_9dof/nodes/imu_node.py", line 40, in <module>
    from razor_imu_9dof.cfg import imuConfig
ImportError: No module named cfg

I could get the sensor working well on other ROS versions and different Ubuntu.

Any idea about why this error ?

Thanks!

edit retag flag offensive close merge delete

Comments

@Cyril_J Did you solve the error? I'm having the same problem. My workaround was to comment out the lines of the node code where a variable of that file is used. Of course, the Dynamic Reconfigure is not available because of that.

andrestoga gravatar imageandrestoga ( 2018-07-03 20:52:08 -0500 )edit
1

At the time I ended up using an older version of the razor_imu_9dof package which just worked fine. But looking at it now, the reason is that you need to build the package with catkin_make in order to generate the files for the dynamic reconfigure. Let me know if it works.

Cyril_J gravatar imageCyril_J ( 2018-07-04 04:05:09 -0500 )edit

Yeah, it works! thanks!

andrestoga gravatar imageandrestoga ( 2018-07-04 12:12:47 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-07-04 12:41:02 -0500

The package razor_imu_9dof needs to be build to generate the Dynamic Reconfigure files.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-03-26 11:58:30 -0500

Seen: 686 times

Last updated: Jul 04 '18