Ask Your Question
0

Twist values for robot insanely large

asked 2015-03-23 16:38:33 -0500

luketheduke gravatar image

Hi All, I am making a robot based off of a wheelchair. When I try to run the bot with the teleop_twist_keyboard node I have to turn up the speed to over 20 in order for the motors to move and then they run extremely quickly. Is this normal? All of the programs I have tried for teleoperation have been in the range of +/- 1.5 or less for all axises. The github repo with the code is here: https://github.com/kk6axq/ros_arduino_bridge.git. Thanks for helping a beginner get on in ROS! Thanks, luketheduke

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2015-03-23 19:00:06 -0500

tfoote gravatar image

That is very high. Units on Twist should be in m/s (see rep 103) 20m/s is ~ 44mph which is a little fast for any wheelchair type application.

Requiring a command that high suggests that your platform's controller is not controlling for speed properly.

edit flag offensive delete link more

Comments

Could you take quick look through thew github repo and see if you could locate the problem? Thanks, Luketheduke

luketheduke gravatar image luketheduke  ( 2015-03-24 12:44:22 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-03-23 16:38:33 -0500

Seen: 60 times

Last updated: Mar 23 '15