Ask Your Question

Segfault urdf_to_collada indigo

asked 2015-03-23 10:55:11 -0600

gpldecha gravatar image

updated 2015-03-23 17:08:02 -0600

gvdhoorn gravatar image

I am trying to convert my urdf to a collada file to use it with MoveIt and FastIK. However when I run the command:

rosrun collada_urdf urdf_to_collada hand.urdf hand.dae

I get a segmentation fault. I ran the same command in debug mode similarly to ros forum question

 gdb --args /opt/ros/indigo/lib/collada_urdf/urdf_to_collada my.urdf my.dae

and I got the following debug output:

[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/".
Program received signal SIGSEGV, Segmentation fault.
0x00007ffff6fdd764 in collada_urdf::ColladaWriter::_loadVertices(shapes::Mesh const*, daeSmartRef<ColladaDOM150::domGeometry>) () from /opt/ros/indigo/lib/

Something to do with loadVertices. In my urdf I have no meshes, I only use URF circle, box and cylinder geometric primitives. Any ideas how to convert a urdf to dae ?

I have attached my hand.urdf

Update : similar issue here

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2015-03-23 11:12:13 -0600

gvdhoorn gravatar image

As far as I know, urdf_to_collada is the only tool for that. You mention you have a cylinder in your urdf. Have you seen robot_model/issues/45?

I've read in multiple answers that the version on Hydro still works.

edit flag offensive delete link more


I have seen it. I have removed all visual elements from the links, only leaving the kinematic chain relation. I am running it again, but the converter takes a very long time (it does not complete or return). How long should the conversion process take ?

gpldecha gravatar image gpldecha  ( 2015-03-23 11:23:09 -0600 )edit

When I've used it, it usually returned almost instantly, depending on the contents of the urdf.

gvdhoorn gravatar image gvdhoorn  ( 2015-03-23 11:26:49 -0600 )edit

I have put my urdf file here: hand.urdf do you get the same problem if you were to try to convert it ?

gpldecha gravatar image gpldecha  ( 2015-03-23 11:39:16 -0600 )edit

Under Hydro no problem: hand.dae. Well, I mean the conversion runs to completion. I cannot say anything about the quality of course.

gvdhoorn gravatar image gvdhoorn  ( 2015-03-23 12:38:51 -0600 )edit

I have tried again and I get the following:

I/O error : No such file or directory I/O error : No such file or directory error : xmlNewTextWriterFilename : cannot open uri

Document successfully written to hand.dae

However there is no hand.dae created.

gpldecha gravatar image gpldecha  ( 2015-03-23 15:09:58 -0600 )edit

Yes, that is an error I've seen earlier. Afaik that (again) only occurs on Indigo. I haven't had time to look into that (and also still have enough Hydro machines to do my work on). I can only suggest to post a 'me too' comment on issues/89.

gvdhoorn gravatar image gvdhoorn  ( 2015-03-24 10:51:15 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower


Asked: 2015-03-23 10:55:11 -0600

Seen: 263 times

Last updated: Mar 23 '15