ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Using UWSim GPS

asked 2015-03-19 10:42:48 -0600

raluse gravatar image


I am a beginner user of UWSim and I was trying to use the GPS sensor. I run "rosrun uwsim uwsim" and the scene with the robot in a tank loads up. I notice that there is a topic "/g500/gps" and I call "rostopic echo /g500/gps". However, this does not give any data. I tried changing the rate in the XML file but this does not have any effect.

How can I use the GPS sensor?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2015-03-19 13:14:45 -0600

Mario Prats gravatar image

Make sure your robot is floating on the surface, GPS doesn't work underwater!

edit flag offensive delete link more


Of course, haha. Thank you very much

raluse gravatar image raluse  ( 2015-03-19 13:20:33 -0600 )edit

Question Tools


Asked: 2015-03-19 10:42:48 -0600

Seen: 216 times

Last updated: Mar 19 '15