remote launch unknown machine

asked 2015-03-18 20:17:32 -0500

Sorry for the long question. Main parts are bolded.

I have two computers, both running Ubuntu 12.04 and ROS Hydro.

One computer, connected by serial cable to a Pioneer3-DX robot, runs the p2os package, openni_launch, openni_tracker, and depthimage_to_laserscan packages. A laptop (master running roscore) is connected wirelessly to the computer on the P3-DX and is able to publish and subscribe to topics (they have bi-directional communication). I would like to launch the above packages from my base laptop.

I tried these methods: roslaunch/XML/machine and roslaunch/XML/node, but have been unsuccessful.

I believe the problem may lie with hostnames and machines. The information for each computer is below...

In my .bashrc, I've added the following lines: export ROS_IP=192.168.0.100 (or 101) and export ROS_MASTER_URI=http://192.168.0.100.

When I use rosnode machine (on either computer) while I run the packages from the onboard computer, the output is:

192.168.0.100
192.168.0.101

I am using the following launch file to test remote launch from my base laptop:

remote_test.launch
<launch>
   <machine name="ECE521"
            address="192.168.0.101"
            user="ecejames01"
            env-loader="/home/jlum/catkin_ws/src/follow_me_main/follow_me/launch/remote_test.sh"
            timeout="20" />

   <node machine="rickoFNP14eedX3" pkg="openni_tracker" name="openni_tracker" type="openni_tracker" />
</launch>

and

remote_test.sh
#!/bin/bash

export ROS_WS=/home/catkin_ws
source $ROS_WS/devel/setup.bash

exec "$@"

When I run remote_test.launch, I get the following error:

jlum@rickoFNP14eedX3:~/catkin_ws$ roslaunch follow_me remote_test.launch 
... logging to /home/jlum/.ros/log/bbbcf880-cdc3-11e4-a1b9-bc7737e7db9b/roslaunch-rickoFNP14eedX3-28276.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

ERROR: unknown machine [rickoFNP14eedX3]

Sorry my question is so long. I just want to make sure all the information is there for you. Thanks in advance.


Information on laptop:

jslum@rickoFNP14eedX3:~$ hostname
rickoFNP14eedX3
jslum@rickoFNP14eedX3:~$ ifconfig
eth0      Link encap:Ethernet  HWaddr 14:da:e9:bf:50:16  
          inet6 addr: fe80::16da:e9ff:febf:5016/64 Scope:Link
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:220833 errors:0 dropped:0 overruns:0 frame:0
          TX packets:15739 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:39199895 (39.1 MB)  TX bytes:2154737 (2.1 MB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:157699 errors:0 dropped:0 overruns:0 frame:0
          TX packets:157699 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:11060159 (11.0 MB)  TX bytes:11060159 (11.0 MB)

wlan0     Link encap:Ethernet  HWaddr bc:77:37:e7:db:9b  
          inet addr:192.168.0.100  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::be77:37ff:fee7:db9b/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:10496 errors:0 dropped:0 overruns ...
(more)
edit retag flag offensive close merge delete