Ask Your Question
0

devel/setup.bash not setting path to src

asked 2015-03-14 18:58:08 -0600

updated 2015-03-15 12:18:06 -0600

My rosserial project is progressing but I've hit a problem where sourcing ~/ros_ws/devel/setup.bash doesn't seem to change the path correctly. The symptom of this is that rospack list shows my custom packages using the path ~/ros_ws/install/share/custom_package and when running catkin_make, my custom messages are ignored because the packages can't be found (for building rosserial messages). I've tried clearing the workspace by sourcing /opt/ros/indigo/share but even when sourcing /devel after that, the paths are shown as /install.

I don't really get why it might not be sourcing the path correctly.

EDIT: posted variables as requested

declare -x ROSLISP_PACKAGE_DIRECTORIES="/home/human/ros_ws/devel/share/common-lisp" 
declare -x ROS_DISTRO="indigo"
declare -x ROS_ETC_DIR="/opt/ros/indigo/etc/ros" 
declare -x ROS_IP="192.168.0.148" 
declare -x ROS_MASTER_URI="http://192.168.0.148:11311/" 
declare -x ROS_PACKAGE_PATH="/home/human/ros_ws/install/share:/home/human/ros_ws/install/stacks:/home/human/ros_ws/src:/opt/ros/indigo/share:/opt/ros/indigo/stacks" 
declare -x ROS_ROOT="/opt/ros/indigo/share/ros" 
declare -x ROS_TEST_RESULTS_DIR="/home/human/ros_ws/build/test_results"
edit retag flag offensive close merge delete

Comments

Could you post your ROS environment variables in the question above?

$export | grep ROS
Andromeda gravatar imageAndromeda ( 2015-03-15 01:43:31 -0600 )edit
1

Updated the question as requested. That was just after sourcing /opt/ros/indigo/setup.bash and /devel/setup.bash so I find it weird that both /install and /devel are being listed on the package path

Wes G gravatar imageWes G ( 2015-03-15 12:18:50 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2015-03-15 21:37:16 -0600

130s gravatar image

Your ROS_PACKAGE_PATH indicates that you already sourced a setup from install space. I assume this time you want to use devel space instead?

If so, an easy solution is to start over building (while I don't fully understand your problem situation).

$ cd %YOUR_CATKIN_Ws_HOME% && rm -fr build devel install
(On a new terminal)
$ cd %YOUR_CATKIN_Ws_HOME% && catkin_make
$ source devel/setup.sh
edit flag offensive delete link more

Comments

1

I ended up resetting my WS into a fresh one, so I suspect this problem is just an artifact of my environment. In the end I learned a lot more about dependencies so I guess it was a win?

Wes G gravatar imageWes G ( 2015-03-16 08:14:39 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-03-14 18:58:08 -0600

Seen: 2,000 times

Last updated: Mar 15 '15