ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question
0

Package dependencies cannot be resolved

asked 2015-03-10 12:47:14 -0500

Incendie gravatar image

updated 2015-03-10 13:05:10 -0500

gvdhoorn gravatar image

I'm a completely new Linux user running Ubuntu 14.04 and trying to install the ros-indigo-desktop-full package and I get the following error:

The following packages have unmet dependencies:

libcheese-gtk23: Depends: cheese-common (= 3.10.2-0ubuntu2) but 3.10.2-0ubuntu2 is to be installed
libcheese7: Depends: libgudev-1.0-0 (>= 146) but 1:204-5ubuntu20.10 is to be installed
            Depends: cheese-common (= 3.10.2-0ubuntu2) but 3.10.2-0ubuntu2 is to be installed
libclutter-1.0-0: Depends: libatk1.0-0 (>= 2.5.3) but 2.10.0-2ubuntu2 is to be installed
                  Depends: libc6 (>= 2.14) but 2.19-0ubuntu6.6 is to be installed
                  Depends: libfontconfig1 (>= 2.9.0) but 2.11.0-0ubuntu4.1 is to be installed
                  Depends: libglib2.0-0 (>= 2.37.3) but 2.40.2-0ubuntu1 is to be installed
                  Depends: libgtk-3-0 (>= 3.3.18) but 3.10.8-0ubuntu1.4 is to be installed
                  Depends: libpango-1.0-0 (>= 1.30) but 1.36.3-1ubuntu1.1 is to be installed
                  Depends: libpangocairo-1.0-0 (>= 1.30) but 1.36.3-1ubuntu1.1 is to be installed
                  Depends: libpangoft2-1.0-0 (>= 1.30) but 1.36.3-1ubuntu1.1 is to be installed
                  Depends: libx11-6 (>= 2:1.2.99.901) but 2:1.6.2-1ubuntu2 is to be installed
                  Depends: libxcomposite1 (>= 1:0.3-1) but 1:0.4.4-1 is to be installed
                  Depends: libxdamage1 (>= 1:1.1) but 1:1.1.4-1ubuntu1 is to be installed
                  Depends: libxi6 (>= 2:1.2.99.4) but 2:1.7.1.901-1ubuntu1 is to be installed
ros-indigo-desktop-full:
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
2

answered 2015-03-10 13:06:31 -0500

gvdhoorn gravatar image

Is this 14.04.2 by any chance?

See if the answer by @demmeln in Ubuntu 14.04.2 unmet dependencies helps you.

edit flag offensive delete link more

Comments

There are several issues with 14.04.2 I'd recommend using 14.04.1 or the original if possible for now, especially if you're just getting started with linux.

tfoote gravatar image tfoote  ( 2015-03-12 13:02:44 -0500 )edit

Question Tools

Stats

Asked: 2015-03-10 12:47:14 -0500

Seen: 785 times

Last updated: Mar 10 '15