Ask Your Question
0

Installing Roboteq_driver package for indigo

asked 2015-03-05 07:36:26 -0500

nouf gravatar image

updated 2015-03-06 09:53:38 -0500

Hello

I tried to install roboteq_driver using this command

sudo apt-get install ros-indigo-roboteq-driver

but gives the following error: E: Unable to locate package ros-indigo-roboteq-driver

Also, i tried installing it using git clone and then catkin_make but then when I list all packages using

rospack list

the package doesn't show and I cannot use it.

Anyone knows how to solve this?

Thank you

UPDATE: I'm using indigo version of ROS that is installed on Ubuntu 14.04

UPDATE 2: I finally figured out the exact problem (which I really don't know how to solve ! :$)

when I installed roboteq_driver and apply catkin_make , It shows the following error:

CMake Error at /opt/ros/indigo/share/catkin/cmake/catkinConfig.cmake:75 (find_package):
  Could not find a package configuration file provided by "serial" with any
  of the following names:

    serialConfig.cmake
    serial-config.cmake

  Add the installation prefix of "serial" to CMAKE_PREFIX_PATH or set
  "serial_DIR" to a directory containing one of the above files.  If "serial"
  provides a separate development package or SDK, be sure it has been
  installed.
Call Stack (most recent call first):
  roboteq/roboteq_driver/CMakeLists.txt:4 (find_package)


-- Configuring incomplete, errors occurred!
See also "/home/nouf/catkin_ws/build/CMakeFiles/CMakeOutput.log".
See also "/home/nouf/catkin_ws/build/CMakeFiles/CMakeError.log".
Invoking "cmake" failed

and that is why all packages after this package couldn't be built

Now, do you know what is this error about?

thank you

edit retag flag offensive close merge delete

Comments

hello,

have you resolved this issue?

thanks, Aaron

UPDATE: sudo apt-get install ros-indigo-serial

fixed it for me

aarontan gravatar image aarontan  ( 2018-05-15 09:25:18 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2015-03-05 07:50:33 -0500

gvdhoorn gravatar image

updated 2015-03-06 05:32:04 -0500

According to the roboteq_driver wiki page, it has been released into Indigo.

Please update your original question with details on which Linux distribution you are using, and which version (the ros-indigo-* pkgs are only available on Ubuntu 14.04 (Trusty) and up).


Edit: ros.org/debbuild/indigo.html?q=roboteq also shows roboteq_driver having been released.

Can you install other ROS packages? Did you complete the installation tutorials?


Edit2:

UPDATE: I'm using indigo version of ROS that is installed on Ubuntu 14.04

but I cannot install any package

yes the update works fine with no errors

Those three statements seem to be conflicting: have you been able to install ros-indigo-desktop(-full) or not?


Edit 3:

I installed ROS as in this link.

and you also did step 1.6 Environment setup?

What is source /path/to/catkin_ws/devel/setup.bash for? and when to use it?

You probably want to read Installing and Configuring Your ROS Environment again, and perhaps wiki/catkin/workspaces - 4.1: Environment Setup File:

If you are ever having problems finding or using your ROS packages make sure that you have your environment properly setup. A good way to check is to ensure that environment variables like ROS_ROOT and ROS_PACKAGE_PATH are set:

$ export | grep ROS

If they are not then you might need to 'source' some setup.*sh files.

Without sourcing the correct setup file, ROS will not be able to find any of the packages in your workspace.

edit flag offensive delete link more

Comments

I did complete the installation. but I cannot install any package

nouf gravatar image nouf  ( 2015-03-05 11:02:35 -0500 )edit

Ok. So you've added the ROS apt server lines to your sources.list.d directory, have run sudo apt-get update and gotten no errors?

gvdhoorn gravatar image gvdhoorn  ( 2015-03-05 11:33:47 -0500 )edit

yes the update works fine with no errors

nouf gravatar image nouf  ( 2015-03-05 12:07:51 -0500 )edit

Yes I installed the full version, but whenever I install additional package or create my own package, ROS can't find it and recognise it as a package although the package folders exist in both src and build folders in catkin_ws

nouf gravatar image nouf  ( 2015-03-06 04:37:04 -0500 )edit

Did you install the binary version of ROS, or did you do a source install?

ROS can't find it and recognise it as a package although the package folders exist in both src and build folders in catkin_ws

And this is after a source /path/to/catkin_ws/devel/setup.bash?

gvdhoorn gravatar image gvdhoorn  ( 2015-03-06 04:49:21 -0500 )edit

I installed ROS as in this link . What is source /path/to/catkin_ws/devel/setup.bash for? and when to use it?

nouf gravatar image nouf  ( 2015-03-06 05:07:44 -0500 )edit

I updated the question, please check it. thanks

nouf gravatar image nouf  ( 2015-03-06 09:54:21 -0500 )edit

You don't have all dependencies installed (which is exactly what the error is telling you). You'll have to install them before trying to build the package. The tutorials should tell you how.

Also: why build from source, as the package has been released as a deb.

gvdhoorn gravatar image gvdhoorn  ( 2015-03-06 10:01:59 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-03-05 07:36:26 -0500

Seen: 1,326 times

Last updated: Mar 06 '15